Closed Bug 407603 Opened 13 years ago Closed 13 years ago

Firefox 2.0.0.11 crashes all the time for no obvious reason

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: _+bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Since I have upgraded to Firefox 2.0.0.11 from 2.0.0.10 through the automatic update, the aplication is highly unstable. Sometimes it runs fine for days, then it crashes every couple of minutes. It crashed when closing a tab, when navigating to a link, when doing anything. After a restart and with the session restored, the very same actions works without a problem. I cannot see any scheme behind it other than Firefox becomes close to unusable from one day to another! Sometimes, I get a debugger window (from Visual Studio) and a crash report is sent automatically, the other day the Firefox window just disappears with no trace. This behaviour can be seen on several computers here, so it's not a hardware problem. I have disabled some of the less important extensions but it doesn't help. All of the extensions and plugins have worked fine over months. So it can't be them, too. I'm now trying to uninstall Firefox and get version 2.0.0.9 which worked for sure. Need to disable auto-update then. I don't want to switch to Opera, and IE is not an option for me.

Reproducible: Sometimes
Update the title to "Firefox 2.x". I installed 2.0.0.9 and one of the first things it did was crashing. I'm running out of ideas. The other computer (my Dad's) is running a different virus scanner, so it can't be that one, too. Deleting all plug-in files (moved them elsewhere) doesn't even seem to update the about:plugins page - they're still there! I hope you get the crash reports that I send you to do something against it... Okay, now let's see how Firefox 3 is doing...
Please post one talkback id from such a crash :
http://kb.mozillazine.org/Talkback
This is the one from 2.0.0.9: TB38956096H
The others are not in the list. Probably deleted by the re-installation.
Here are more:
TB38982957K 2007-12-10 15:41 (right now)
TB38955717M 2007-12-09 20:17
TB38944516M 2007-12-09 13:56
TB38653894W 2007-12-01 11:50
Oh, look, today is happy crash day. Get a free crash every hour.*
TB38987266M 2007-12-10 17:44
This one was while removing a waypoint from Google Maps in satellite view. As always (until now), the session could be restored after the restart.

*) Only valid as long as you're interactively using the application. Non-negotiable to other users.

BTW, this one and the four before were with 2.0.0.11 installed. I have no idea why the older ones suddenly showed up again after the upgrade.
Do you get the same in the Firefox safemode ?
http://kb.mozillazine.org/Safe_Mode
I don't know. I really don't intend to use Firefox the whole day in safe mode with no extensions and plugins. To get a reasonable result, I'd need to wait maybe two weeks to see if it's stable. I could use Opera as well and have more comfort. It's only the extensions, that make Firefox better.
This one wasn't caught by Talkback. Happens, too. I'm not sure what information you can use, so here's what I can find in VS2005:

Unbehandelte Ausnahme bei 0x6010224c in firefox.exe: 0xC0000005: Zugriffsverletzung beim Lesen an Position 0x00000008.

Call stack:
>	js3250.dll!6010224c() 	
 	[Unten angegebene Rahmen sind möglicherweise nicht korrekt und/oder fehlen, keine Symbole geladen für js3250.dll]	
 	js3250.dll!60101f64() 	
 	js3250.dll!60101e17() 	
 	js3250.dll!60102875() 	
 	firefox.exe!00429171() 	
 	firefox.exe!0041059b() 	
 	xpcom_core.dll!6039a4b4() 	
 	xpcom_core.dll!6039a8f6() 	
 	firefox.exe!00428a86() 	
 	firefox.exe!00429973() 	
 	ntdll.dll!7c9206eb() 	
 	msvcrt.dll!77bfc3c9() 	
 	msvcrt.dll!77bfc3ce() 	
 	NPSWF32.dll!300835d6() 	
 	firefox.exe!00428542() 	
 	firefox.exe!0058bc4d() 	
 	firefox.exe!0058bbae() 	
 	firefox.exe!006228f7() 	
 	xpcom_core.dll!603617e0() 	
 	firefox.exe!0058bc2c() 	
 	firefox.exe!005d5de3() 	
 	firefox.exe!00609e19() 	
 	NPSWF32.dll!3007f993() 	
 	NPSWF32.dll!30080b3f() 	
 	NPSWF32.dll!3008217d() 	
 	NPSWF32.dll!3008b751() 	
 	NPSWF32.dll!3008c6d7() 	
 	NPSWF32.dll!3008c792() 	
 	NPSWF32.dll!3008c8a0() 	
 	NPSWF32.dll!3009e916() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00609df3() 	
 	NPSWF32.dll!3008c792() 	
 	NPSWF32.dll!3008c8a0() 	
 	NPSWF32.dll!3009e916() 	
 	NPSWF32.dll!3008c8a0() 	
 	NPSWF32.dll!30083284() 	
 	NPSWF32.dll!30083284() 	
 	firefox.exe!00638fee() 	
 	firefox.exe!00638fee() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00609df3() 	
 	NPSWF32.dll!3007f993() 	
 	NPSWF32.dll!3001d16a() 	
 	NPSWF32.dll!3001d16a() 	
 	NPSWF32.dll!30083de6() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00589e5c() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00609df3() 	
 	NPSWF32.dll!3007fa73() 	
 	NPSWF32.dll!30083284() 	
 	NPSWF32.dll!300835d6() 	
 	NPSWF32.dll!30083284() 	
 	NPSWF32.dll!300835d6() 	
 	firefox.exe!00660330() 	
 	firefox.exe!005ec10f() 	
 	firefox.exe!0063dd3a() 	
 	firefox.exe!0063c316() 	
 	firefox.exe!0063c270() 	
 	ntdll.dll!7c920732() 	
 	ntdll.dll!7c920732() 	
 	firefox.exe!00589e5c() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00609df3() 	
 	NPSWF32.dll!3001d16a() 	
 	NPSWF32.dll!30081139() 	
 	NPSWF32.dll!30081188() 	
 	NPSWF32.dll!3008c792() 	
 	firefox.exe!007898cd() 	
 	firefox.exe!00789b0f() 	
 	firefox.exe!00621397() 	
 	firefox.exe!00794066() 	
 	xpcom_core.dll!603617c0() 	
 	firefox.exe!007856e1() 	
 	firefox.exe!007898e1() 	
 	xpcom_core.dll!603617e0() 	
 	firefox.exe!00621397() 	
 	xpcom_core.dll!603617f3() 	
 	firefox.exe!006405dd() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00630d49() 	
 	xpcom_core.dll!603617f3() 	
 	firefox.exe!006405dd() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00609df3() 	
 	NPSWF32.dll!30083284() 	
 	NPSWF32.dll!30083284() 	
 	firefox.exe!00669f53() 	
 	firefox.exe!0066938b() 	
 	firefox.exe!006b61a2() 	
 	gdi32.dll!77ef8ef9() 	
 	gdi32.dll!77ef939d() 	
 	gdi32.dll!77ef92ec() 	
 	firefox.exe!0064429b() 	
 	firefox.exe!00589e5c() 	
 	firefox.exe!00609df3() 	
 	ntdll.dll!7c920732() 	
 	ntdll.dll!7c920732() 	
 	ntdll.dll!7c9206ab() 	
 	ntdll.dll!7c9206eb() 	
 	user32.dll!7e3694be() 	
 	user32.dll!7e36b42d() 	
 	user32.dll!7e36b3f9() 	
 	user32.dll!7e36b393() 	
 	user32.dll!7e36b3a7() 	
 	user32.dll!7e36b3a7() 	
 	firefox.exe!00550f86() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e36885a() 	
 	firefox.exe!00609df3() 	
 	user32.dll!7e36c665() 	
 	firefox.exe!00550f23() 	
 	xpcom_core.dll!603617e0() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e368816() 	
 	user32.dll!7e36885a() 	
 	user32.dll!7e36882a() 	
 	user32.dll!7e36882a() 	
 	user32.dll!7e36b4c0() 	
 	user32.dll!7e36b4cb() 	
 	user32.dll!7e36b4cb() 	
 	user32.dll!7e36b50c() 	
 	user32.dll!7e36b51c() 	
 	ntdll.dll!7c91eae3() 	
 	user32.dll!7e3694be() 	
 	user32.dll!7e36b42d() 	
 	xpcom_core.dll!6036149a() 	
 	firefox.exe!00609df3() 	
 	firefox.exe!00550f86() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e368816() 	
 	user32.dll!7e36885a() 	
 	user32.dll!7e36882a() 	
 	kernel32.dll!7c830c6f() 	
 	user32.dll!7e36882a() 	
 	user32.dll!7e36c63f() 	
 	user32.dll!7e36c665() 	
 	firefox.exe!00550f23() 	
 	xpcom_core.dll!603617e0() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e368816() 	
 	user32.dll!7e36885a() 	
 	user32.dll!7e36882a() 	
 	user32.dll!7e36882a() 	
 	user32.dll!7e36b4c0() 	
 	user32.dll!7e36b4cb() 	
 	user32.dll!7e36b4cb() 	
 	user32.dll!7e36b50c() 	
 	firefox.exe!0060b14d() 	
 	firefox.exe!0062288c() 	
 	firefox.exe!0058bc2c() 	
 	firefox.exe!0058ba99() 	
 	firefox.exe!005a2640() 	
 	firefox.exe!006424e9() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e368816() 	
 	user32.dll!7e36885a() 	
 	user32.dll!7e36882a() 	
 	kernel32.dll!7c830c6f() 	
 	user32.dll!7e36c63f() 	
 	firefox.exe!006424bf() 	
 	firefox.exe!00550f23() 	
 	xpcom_core.dll!603617e0() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e368816() 	
 	user32.dll!7e36885a() 	
 	user32.dll!7e36882a() 	
 	firefox.exe!006424bf() 	
 	user32.dll!7e36b4cb() 	
 	user32.dll!7e36b4cb() 	
 	user32.dll!7e36b50c() 	
 	user32.dll!7e36b51c() 	
 	ntdll.dll!7c91eae3() 	
 	user32.dll!7e3694be() 	
 	user32.dll!7e36b42d() 	
 	firefox.exe!006424bf() 	
 	ntdll.dll!7c920732() 	
 	ntdll.dll!7c9206ab() 	
 	ntdll.dll!7c9206eb() 	
 	firefox.exe!00550f86() 	
 	firefox.exe!00660d03() 	
 	firefox.exe!00660e40() 	
 	firefox.exe!006424bf() 	
 	firefox.exe!005ed1bb() 	
 	firefox.exe!00660d03() 	
 	firefox.exe!00660e40() 	
 	firefox.exe!005ed1bb() 	
 	firefox.exe!006424bf() 	
 	firefox.exe!005ed24b() 	
 	firefox.exe!005eb512() 	
 	msvcrt.dll!77bfc3c9() 	
 	msvcrt.dll!77bfc3ce() 	
 	firefox.exe!006424bf() 	
 	xpcom_core.dll!603683b8() 	
 	firefox.exe!005eb512() 	
 	firefox.exe!005eb85d() 	
 	firefox.exe!005eb618() 	
 	firefox.exe!006424bf() 	
 	ntdll.dll!7c920732() 	
 	ntdll.dll!7c9206ab() 	
 	ntdll.dll!7c9206eb() 	
 	firefox.exe!005eb85d() 	
 	firefox.exe!005eb8c8() 	
 	firefox.exe!005eb8e4() 	
 	firefox.exe!005eb85d() 	
 	firefox.exe!005eb8c8() 	
 	firefox.exe!006424bf() 	
 	firefox.exe!005eb8c8() 	
 	firefox.exe!005eb8e4() 	
 	ntdll.dll!7c92056d() 	
 	firefox.exe!005eb618() 	
 	firefox.exe!005eb7c9() 	
 	firefox.exe!005eb85d() 	
 	firefox.exe!005eb8c8() 	
 	firefox.exe!006424bf() 	
 	firefox.exe!006644f7() 	
 	firefox.exe!00664500() 	
 	firefox.exe!00662247() 	
 	firefox.exe!005869f0() 	
 	firefox.exe!00584928() 	
 	firefox.exe!00584b34() 	
 	firefox.exe!00584b83() 	
 	firefox.exe!0057e2da() 	
 	firefox.exe!00583372() 	
 	firefox.exe!0057dd66() 	
 	firefox.exe!005ebd71() 	
 	firefox.exe!0066022a() 	
 	firefox.exe!005eb07b() 	
 	firefox.exe!0065ffdb() 	
 	firefox.exe!00660961() 	
 	firefox.exe!00550b5a() 	
 	firefox.exe!00550b9e() 	
 	firefox.exe!005556e1() 	
 	user32.dll!7e36b4cb() 	
 	firefox.exe!00555b6d() 	
 	firefox.exe!0055436b() 	
 	user32.dll!7e3694be() 	
 	user32.dll!7e36b42d() 	
 	user32.dll!7e36b3f9() 	
 	user32.dll!7e36b393() 	
 	user32.dll!7e36b3a7() 	
 	user32.dll!7e36b3a7() 	
 	firefox.exe!00550f86() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e368816() 	
 	user32.dll!7e36885a() 	
 	user32.dll!7e36882a() 	
 	kernel32.dll!7c830c6f() 	
 	user32.dll!7e36882a() 	
 	user32.dll!7e36c63f() 	
 	ntdll.dll!7c91f0aa() 	
 	ntdll.dll!7c91d9c1() 	
 	kernel32.dll!7c830c6f() 	
 	kernel32.dll!7c830c88() 	
 	user32.dll!7e36f896() 	
 	user32.dll!7e36baa4() 	
 	firefox.exe!00558ba8() 	
 	firefox.exe!00550394() 	
 	xpcom_core.dll!603617a0() 	
 	firefox.exe!00550f04() 	
 	user32.dll!7e368734() 	
 	user32.dll!7e368816() 	
 	user32.dll!7e3689cd() 	
 	user32.dll!7e369402() 	
 	user32.dll!7e368a10() 	
 	firefox.exe!0055cec3() 	
 	firefox.exe!00851ea3() 	
 	firefox.exe!00402725() 	
 	msvcrt.dll!77c0412a() 	
 	msvcrt.dll!77c06cde() 	
 	ntdll.dll!7c92094e() 	
 	firefox.exe!00401012() 	
 	firefox.exe!0040102e() 	
 	firefox.exe!00966de2() 	
 	kernel32.dll!7c816fd7() 	
 	firefox.exe!00530057() 	
 	firefox.exe!004b0063() 	
 	firefox.exe!00530022() 	
 	firefox.exe!00650044() 	
 	firefox.exe!00630072() 	
 	firefox.exe!006e0065() 	
 	firefox.exe!00690073() 	
 	firefox.exe!00530057() 	
 	firefox.exe!00630072() 	
 	firefox.exe!006e0065() 	
 	firefox.exe!00690073() 	
 	firefox.exe!00530057() 	
 	firefox.exe!00630072() 	
 	firefox.exe!006e0065() 	
 	firefox.exe!00690073() 	
 	firefox.exe!00530057() 	
 	firefox.exe!00620038() 	
 	firefox.exe!00620038() 	
 	firefox.exe!00630072() 	
 	firefox.exe!006e0065() 	
 	firefox.exe!00690073() 	
 	firefox.exe!00530057() 	
 	firefox.exe!00530057() 	
 	firefox.exe!00530057() 	
 	firefox.exe!00530057() 	
 	firefox.exe!00530057() 	

This is the line that caused the problem:
6010224C  mov         edi,dword ptr [eax+4] 

Here's all lines around it:
60102237  push        ebx  
60102238  mov         ebx,dword ptr [esp+8] 
6010223C  push        esi  
6010223D  push        edi  
6010223E  mov         eax,dword ptr [ebx+34h] 
60102241  test        eax,eax 
60102243  je          6010227B 
60102245  mov         eax,dword ptr [eax+0Ch] 
60102248  mov         esi,dword ptr [esp+14h] 
6010224C  mov         edi,dword ptr [eax+4] 
6010224F  add         edi,dword ptr [eax] 
60102251  jmp         60102277 
60102253  movzx       ecx,byte ptr [esi] 
60102256  mov         edx,ecx 
60102258  shl         edx,4 
6010225B  test        byte ptr [edx+6012E805h],20h 
60102262  jne         601022D5 
60102264  cmp         ecx,40h 
60102267  je          60102281 
60102269  cmp         ecx,3Bh 
6010226C  je          60102290 
6010226E  cmp         ecx,83h 
60102274  jne         6010227B 
60102276  inc         esi  
60102277  cmp         esi,edi 
60102279  jb          60102253 

Continuing execution ignoring the error makes VS2005 eat up all CPU time. So I quit it.

Whatever is going on here, I guess an unclean application termination is not the way it is intended by the Firefox developers. (At least I wouldn't intend that in my own applications.)

HTH (I guess not but I'm doing what I can.)
TB39021024K 2007-12-11 15:14
This looks like addon related, the raw doesn't help but the tailback Id's are enough.
I'm unable to do more if you don't want to run in the safe mode . A list of installed ad dons may help other people triaging this bug report.
Okay, here's my add-on list currently installed and activated:
Adblock Plus 0.7.5.3
DOM Inspector 1.8.1.11
Download Manager Tweak 0.7.2 *
Firebug 1.05 *
Greasemonkey 0.7.20070607.0 *
IDN Info 0.6.6 *
IE Tab 1.3.3.20070528 *
LastTab 2.0.5 *
Live HTTP Headers 0.13.1 *
Mouse Gestures 1.5.2
Restore Scroll Position 0.5.4 *
Reuse Home Page 1.3 *
Rewind/Fastforward Buttons 2.0.2007110603 *
Stop-or-Reload Button 0.2.2 *
SubmitToTab [de] 0.3.5 *
Talkback 2.0.0.11
TargetKiller 0.4 *
Undo Closed Tabs Button 2.0 *
User Agend Switcher 0.6.10 *
Web Developer 1.1.4 *

The ones marked with a * have been deactived for some time but Firefox would still crash.
Recent weeks Firefox 2.0.0.11 crashing constantly navigating into my AOL webmail. Famous last words "Windows is looking for an answer to this problem." IE not my favorite. Besides on this HP laptop with Vista must use IE-64 bit. 32-bit doesn't accept key strokes. And IE 64 bit can't use adobe flash etc etc. Besides I am used to Firefox. It has all of my bookmarks. 
Damn, how I hate that. It worked for a few weeks again, and from today on, for no apparent reason, it keeps crashing again. I'm beginning to doubt Mozilla's QA and code stability. (I mean, if my crash reports - where sent - cannot help find the bug...) It's slow and memory-consuming enough to contain tons of bugs that may cause instability. I'll need to consider using another browser for time-critical stuff.
Is there not some way to help this terrible situation? Life without Firefox is really bad. It does not help to recite an endless list of the Symptoms. Firefox is crashing around our heads. We all are able to recite when it happens, how often it happens, what keystroke we were on when it happened the last time, etc. What we need is a Firefox Person to help us. How does one go about finding a Firefox Person or Mozilla Person to whom one can speak. Surely there is a human who can tell what has been happening to Mozilla Firefox, so we can re-establish the solid connection, and keep connected----whether we are XP Vista or or anything else. Does anyone know who to call or write to???
ONE  I am looking over the list of add-ons kindly provided above. I do not have those. However, the most recent add-on which might correlate with the onset of the Firefox Crash Epidemic/Scourge/Plague on this computer was a little sunflower called Instant Computer Help which is offered by Mozilla as an add-on toolbar. I would like to experiment by removing this. BUT I can't seem to find it anywhere in order to un-install it. Anybody have a suggestion where to find it?  Another problem with Firefox which began at the same time it became undependable is that it suddenly would not print on any of my printers or my Adobe 8 pdf. Anyone with that kind of trouble?

 TWO  I notice that the only IE I can use with this HP Vista laptop is 64-bit. I do not actually know what that signifies. But 64-bit won't accept any flash add-on and it is also resists copying for Adobe pdf.  

 I am only hoping to solve the Firefox problem and simply add the TWO above in the event anybody can put these problems together and make sense of them.  
Naomi S. Christman: why are you posting in this bug with a general description ?
Unless you have a stacktrace (from a debugger or Talkback) which looks identical you can't be sure that you see the same bug. 
You have to write your own bug with a short and good technical desciption, with a Talkback id and if you are sure that you get your crashes also in the Firefox safemode.


Would you recommend naming the new talkback IDs of today here?

Why does a bug need to appear in safe mode? Some bugs just cannot be "tested", like this one. This observed instability is much too unspecific that I could say, wait, I'll test if it happens again. It happened every couple of minutes, then - with no software upgrade or intended configuration change - it stopped for three weeks. Today it just started again. Should I browse the web in safe mode for three weeks? Would we know for sure that it doesn't happen in safe mode then? What if tomorrow it works fine again for another six weeks... (Well, I hope Firefox 3 will be out by then. And it be more stable. And add-ons have updated...)
Thank you. Please explain the words stacktrace and Talkback. I shall look for it/them and am glad to follow directions. I see Firefox and Firefox Safemode in my programs. I shall try out Firefox Safe Mode and observe if there is a difference in its behavior with that of ordinary Firefox. Thank you.

Meanwhile, How would I go about getting a stacktrace that "looks identical?" That is, what would the stacktrace be identical TO? How shall I find the stacktrace?

Thank you.
it has to appear in the safemode because you are sure that this is not caused by an addon.
If it's caused by an addon you have to find out which one and we can look if if your problem is caused by a Firefox bug or by a bug in the addon.
The other way would be clear steps to reproduce. I can't reproduce this with a german winxp and a german 2.0.11 Firefox (but i don't have addons installed).
Your stacks (from the TB IDs) are different and also in JS/DOM and that makes it impossible for me to do something with this bug report in the current state.
Maybe somebody else can but I don't think that someone will spent much time with this if he can't reproduce this.

Naomi S. Christman: see comment 2 and comment 4 how to get a Talkback id that leads to a stacktrace. It's no problem if you don't know about this stuff, it's just means that you shouldn't comment in this bug report because you don't know if you have the same problem.Create your own report with the needed information. Bugzilla is no support Forum , it's a working tool for the developers.
Sorry, I don't know of a way to reproduce this crash. (If it has a single cause at all.) If I knew, I'd tell! It just happens in so many different situations, I'd consider it random. Running Firefox in safe mode for productive work for a few months (with still no guarantee) is really not an option. For anybody I guess.

Alright, so nobody will help me with this problem. Firefox will continue to run unstable from time to time. At least on two computers. Maybe only on those two that I know. Normally I would say "Firefox sucks" and turn away. But I can't. I know that I've become dependent on it. Like I'm depending on Windows. Guess this is my destiny. Maybe in ten years, another Blake Ross will create a cool new web browser... ;)

Thanks for your effort.
It also happens to me, I have
Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.11) Gecko/20071127
Firefox/2.0.0.11 with no further extension installed.

It often crashes, let's say once every 10 use sessions, while I'm doing nothing
particular, for instance when I'm on youtube... but I noticed it often crashes
when I close a tab or when I open a new blank tab... Visual Studio Debug always
says Access Violation and the Disassembly of the execution thread is often
blocked on one of these two instructions:
6011CB7C  mov         al,byte ptr [esi] 
but esi is not null, or
027EC9E6  mov         byte ptr ds:[00000103h],al
again, this time on closing
in js3250.dll at
600EEC4B  sub         ecx,dword ptr [eax] 
eax is null

WTF has done the developers team this time? they mis-published a prealpha?!!
Incident ID: 38956096 is bug 237823
Incident ID: 38982957 is bug 319533
Incident ID: 38987266 (also TB38987266M) is probably bug 317283 
Incident ID: 38955717 (also TB39021024K) is now bug 415515

This bug is a lightning rod. 

alberto.email@tiscali.it: please be polite or go away. please note that build to build, release to release addresses vary, given that you didn't specify a build there's no way for us to know what in the world you're talking about. fwiw, addresses can change run to run. also just because something is null doesn't mean it was the responsibility of that code to ensure it wasn't null, often it's the job of someone else not to pass null, this is called a contract.

If you dig a hole in the road and i walk across it and fall in the hole, in many states, it's not my fault, it's yours, you weren't supposed to dig the hole in the road. now if we have an agreement that whenever i cross this street i have to look out for holes in the road, then it's my fault. but without knowing the sequence of events (stack trace), it's impossible to know what agreements are enforced, all we have is "ouch" (as it happened, I recently fell and my leg did go ouch, I think I'll blame you, since you're convenient, that's fair right?)
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.