as I delete items from the "Most Visited" query in the places organizer, I don't see updates until switch to another item and switch back

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: moco, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

as I delete items from the "Most Visited" query in the places organizer, I don't see updates until switch to another item and switch back

steps to reproduce:

1) create a new profile and visit 20 unique sites
2) open the places organizer, in the left hand pane select "Smart Bookmarks" | "Most Visited"
3) in the right hand pane, delete 5 of the items

expected results:  as I delete items, we should continue to show the ten most recent visited sites.

actually results:  I only see 5, until I switch to another item in the left hand pane and then switch back.

note, "Recent Bookmarks" doesn't have this problem (which is a bookmark query, not a history query.)

Comment 1

11 years ago
In the bookmarks toolbar "delete" on the "most visited" items doesn't work at all: bug 407872.
i think that this has the same cause of Bug 407612

Most Visited items are history ones, since the organizer and menus are based on bookmark id, they have itemId = -1
wfm on trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.