User-added toolbars will not stay hidden

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: ehume, Unassigned)

Tracking

3.6 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

For a long time, I kept a user-made toolbar on my Firefox 1.0, 1.5, 2.0 and 3.0 installations to hold buttons that I do not use, but which I must skin in my themes. When I wasn't checking these buttons for correctness of skin, I would keep the toolbar hidden. When Firefox was started, the user-added toolbar would not be visible. It would only be visible if I checked it in the View > Toolbars menu or in the toolbars context menu.

Some time in October or November, this toolbar started showing up when I started Firefox. I figured I had a conflict with an extension or a corrupted localstore.rdf file.

Today, I tested that hypothesis with a clean profile. Same results: a user-added toolbar shows up on Firefox startup, even when it has been deslected on the toolbar list.

The toolbar for the All-In-One Sidebar extension does not have this problem: it is only visible when I tell it to be visible.

Reproducible: Always

Steps to Reproduce:
1. In Customize Toolbars mode, create a new toolbar.
2. Add a toolbar button to the new toolbar (otherwise it will disappear).
3. End Customize Toolbars mode.
4. Right-click on the new toolbar.
5. Un-check the new toolbar from the context menu.
6. Close and restart Firefox.
Actual Results:  
The new toolbar is visible.

Expected Results:  
The new toolbar should not be visible.

This behavior started some time in October or November of 2007.

Comment 1

10 years ago
In October 2008 I started using Firefox (v3.0.3) This problem existed then. I now have Firefox (v3.0.5) and this problem still exists.

I would like to create some custom toolbars that don't appear everytime Firefox starts!

I am surprised that this problem is still classified as "UNCONFIRMED" after reading that it has been known to Mozilla for some time now.

It is very easy to reproduce.
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
(Reporter)

Comment 3

8 years ago
No longer a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME

Comment 4

8 years ago
(In reply to comment #3)
> No longer a problem.

Still is a problem with Firefox 3.6.11

Created a new profile.
Created a new toolbar
Added a button to the new toolbar.
Unchecked the toolbar to hide it.
Closed Firefox.
Started Firefox - Result the new taskbar reappeared.

Comment 5

8 years ago
Forgot to mention the problem still existed on Firefox 3.6.11 running under Windows 7 Ultimate.

Comment 6

8 years ago
(In reply to comment #5)
> Forgot to mention the problem still existed on Firefox 3.6.11 running under
> Windows 7 Ultimate.
32 bit

I can't change the resolution in the status or the comment in the whiteboard
(In reply to comment #6)
>I can't change the resolution in the status or the comment in the whiteboard

Because you are not the reporter. The original reporter says this is no longer a problem. If you are still seeing this, please file a new bug.
(Reporter)

Comment 8

8 years ago
I just now tried it, both with a sidebar added by an extension and a testbar added with Firefox native toolbar customization. WFM.

Blaine, this may be due to an extension conflict. Or a bunged-up profile. Often deleting all the files in your profile named extensions.xxx (with Firefox closed) will solve a problem like this.

Comment 9

8 years ago
(In reply to comment #7)
> (In reply to comment #6)
> >I can't change the resolution in the status or the comment in the whiteboard
> 
> Because you are not the reporter. The original reporter says this is no longer
> a problem. If you are still seeing this, please file a new bug.

Thank you, I will file a new bug report.

Comment 10

8 years ago
(In reply to comment #8)
> I just now tried it, both with a sidebar added by an extension and a testbar
> added with Firefox native toolbar customization. WFM.
> 
> Blaine, this may be due to an extension conflict. Or a bunged-up profile. Often
> deleting all the files in your profile named extensions.xxx (with Firefox
> closed) will solve a problem like this.

Ed, as I mentioned in comment #4, I created a new profile. I also did not install any extensions. So there aren't any extensions in the profile. I realize what you mentioned could be a problem. That is why I created a new profile and didn't install any extensions. I only used the new profile when testing for this problem. Since no extensions were installed I could only use the native toolbar customization. Also note the test toolbar was the only toolbar other than the native toolbars.

I am aware of this because problems in the past have happened from an installed extension conflict and/or a messed up profile. Thank you for your suggestion.

It would be interesting to know what OS you are currently using and whether it is 32 or 64 bit. I mentioned I'm using Windows 7 Ultimate (32 bit).
(Reporter)

Comment 11

8 years ago
Win 7 64-bit.

Relevant installed extensions: MR Tech Toolkit, TotalToolbar, Toolbar Buttons.

Comment 12

8 years ago
(In reply to comment #11)
> Win 7 64-bit.
> 
> Relevant installed extensions: MR Tech Toolkit, TotalToolbar, Toolbar Buttons.

I think I see why it works for you and not for me. You are using the 64 bit version and I'm using the 32 bit version. The problem was probably resolved in the 64 bit version and not the 32 bit version.

I'll add that relevant information to the new bug report that I am in the process of filing.

Thank you very much!

Comment 13

8 years ago
(In reply to comment #9)
> (In reply to comment #7)
> > (In reply to comment #6)
> > >I can't change the resolution in the status or the comment in the whiteboard
> > 
> > Because you are not the reporter. The original reporter says this is no longer
> > a problem. If you are still seeing this, please file a new bug.
> 
> Thank you, I will file a new bug report.

New bug report submitted (Bug 606017)- User added toolbars will not stay hidden when restarting Firefox. Refer to previous Bug 407626

Comment 14

8 years ago
(In reply to comment #11)
> Win 7 64-bit.
> 
> Relevant installed extensions: MR Tech Toolkit, TotalToolbar, Toolbar Buttons.

Did you test with TotalToolbar active or not active? On its homepage, the 'Features' described for TotalToolbar include fixing/circumventing this bug. Hence testing with it active would not show the bug whether or not it is fixed in Firefox 3.6.11.

Comment 15

8 years ago
(In reply to comment #14)
> (In reply to comment #11)
> > Win 7 64-bit.
> > 
> > Relevant installed extensions: MR Tech Toolkit, TotalToolbar, Toolbar Buttons.
> 
> Did you test with TotalToolbar active or not active? On its homepage, the
> 'Features' described for TotalToolbar include fixing/circumventing this bug.
> Hence testing with it active would not show the bug whether or not it is fixed
> in Firefox 3.6.11.

Thank you RDL.

The TotalToolbar extension does indeed resolve this problem.

With TotalToolbar 1.7 installed, the user added toolbar remains hidden in Firefox 3.6.11.

Without it installed the bug exists! It is not available from Firefox addons. I had to install it from http://totaltoolbar.mozdev.org/
(Reporter)

Comment 16

8 years ago
OOOPS!

I disabled Total Toolbar, and there is the bug. It lives.

Can't resolve it any more.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INCOMPLETE

Comment 18

8 years ago
Just tested with Firefox 3.6.12 and a new profile. The problem still exists.

Comment 19

8 years ago
(In reply to comment #16)
> OOOPS!
> 
> I disabled Total Toolbar, and there is the bug. It lives.
> 
> Can't resolve it any more.

Ah. Then you should probably remove the 'CLOSEME' whiteboard as requested in comment #2 and, if you are able, change the status to 'confirmed' or at least 'new'.

Comment 20

8 years ago
(In reply to comment #17)
> No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new
> profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to
> see this issue with the newest firefox and a new profile, then please comment
> on this bug.
Please see comment #16 (pre 3.6.12, reply explains false negative)
and comment #18 (confirming for 3.6.12 fresh profile as requested)
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [CLOSEME 2010-11-15]
(Reporter)

Updated

8 years ago
OS: Windows XP → All
Version: unspecified → 3.6 Branch

Comment 21

8 years ago
(In reply to comment #16)
> OOOPS!
> 
> I disabled Total Toolbar, and there is the bug. It lives.
> 
> Can't resolve it any more.

But apparently, despite that and comment #18, you still want it closed?

If not, please see

A Bug's Life Cycle
https://bugzilla.mozilla.org/page.cgi?id=fields.html#status

and take appropriate action.
(Reporter)

Comment 22

8 years ago
Does anyone know how to reopen this bug?

I can't "take appropriate action" if the tools aren't there.
Whiteboard: Please reopen this bug. The flaw is still there.
Ed, it is right at the bottom of the bug under status.
Status: VERIFIED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: Please reopen this bug. The flaw is still there.

Updated

8 years ago
Duplicate of this bug: 606017
(Reporter)

Comment 25

8 years ago
Status options are Unconfirmed and Resolved. There is no option to reopen the bug.
UNCONFIRMED is open.
The Firefox 29 customization improvements (part of "Australis") rewrote the code for customization and I'm pretty sure this isn't an issue anymore with it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.