Firefox crashes when I close it. Sometimes it crashes when I work with Firebug

VERIFIED INCOMPLETE

Status

()

VERIFIED INCOMPLETE
11 years ago
7 years ago

People

(Reporter: iverbitskiy, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Hello,

There is one strange bug. I think that it's because of Firebug. But Firebug is only add-on for Firefox, so this problem could be in the kernel or add-ons engine. 
The first issue is segmentation fault when I close the browser. Sometimes it crashes when I'm trying to do something with Firebug.

I have these issues after the version when you fixed several memory leaks issues. I read about this in the news-letter. I think that this issue is because of that memory leaks optimization, because error is segmentation fault.

Regards,
Ilya

Reproducible: Sometimes

Steps to Reproduce:
1.Close the browser

or 

2. Try to use Firebug (but it happens not always)

Comment 1

11 years ago
Hi. Any chance you could try to explain in more detail what you are doing when Firefox crashes? Do you have Talkback (quality feedback agent) installed? Instructions about checking for and installing Talkback are available on http://support.mozilla.com/kb/Quality+Feedback+Agent . Please try to use Talkback to get us a stack for the crash. Thanks!
Keywords: qawanted

Comment 2

10 years ago
=> incomplete due to no response.
If you still see this problem using 3.1 beta please comment.
http://www.mozilla.com/en-US/firefox/all-beta.html
If you still see this please include breakpad reporter id in your comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED

Comment 3

7 years ago
This started happening to me this morning. I realize people submitting bugs always say out of the blue, but I use Firefox a lot, and this issue started this morning. I did perform Ubuntu 10.04 updates yesterday. I do not remember what was updated offhand.

Once I disabled Firebug, the problem went away.

Comment 4

7 years ago
I just re-enabled FireBug, reproduced the bug, and got this:

Add-ons: firebug@software.joehewitt.com:1.8.4,tinyurl.addon@fast-chat.co.uk:2.5.1,{73a6fe31-595d-460b-a920-fcc0f8843232}:2.1.9,langpack-en-GB@firefox.mozilla.org:9.0,testpilot@labs.mozilla.com:1.1.2,{972ce4c6-7e08-4474-a285-3208198ce6fd}:9.0
BuildID: 20111116015832
CrashTime: 1321548081
EMCheckCompatibility: true
Email: cnorton@town.arlington.ma.us
FramePoisonBase: 00000000f0dea000
FramePoisonSize: 4096
InstallTime: 1321536084
Notes: GLXtest process failed (exited with status 1): GLX version older than the required 1.3


ProductName: Firefox
ReleaseChannel: beta
SecondsSinceLastCrash: 2803
StartupTime: 1321548072
Theme: classic/1.0
Throttleable: 1
URL: wyciwyg://2/http://talkgadget.google.com/talkgadget/notifierclient?client=sm&prop=iGoogle&nav=true&fid=gtn-roster-iframe-id&ts=0&debug=undefined&os=Linux%20i686&stime=1321548079730&fb=true&re=false&no=undefined&hc=true&ref=false&xpc=%7B%22cn%22%3A%22j7qxwt%22%2C%22tp%22%3A1%2C%22ifrid%22%3A%22gtn-roster-iframe-id%22%2C%22pu%22%3A%22http%3A%2F%2Ftalkgadget.google.com%2Ftalkgadget%2F%22%2C%22lpu%22%3A%22http%3A%2F%2Fwww.google.com%2Frobots.txt%22%2C%22ppu%22%3A%22http%3A%2F%2Ftalkgadget.google.com%2Frobots.txt%22%7D&pvt=undefined&href=http%3A%2F%2Fwww.google.com%2F%3Frel%3D1&css=http%3A%2F%2Figoogle-skins.googleusercontent.com%2Fig%2Fskin_xml_to_css%3Fv2%3D1%26url%3Dskins%252Fclassic.xml%26skindx%3Dix%3A0%26hl%3Den%26fp%3Dl6z30H3aW0g%26jfk%3D1&hl=en&uj=octopusgrabbus%40gmail.com&vp=http%3A%2F%2Fwww.google.com%2Fig%2Ftalk_xpc_blank.html&host=1&zx=cktfkhha9qbj
Vendor: Mozilla
Version: 9.0

This report also contains technical information about the state of the application when it crashed.
You need to log in before you can comment on or make changes to this bug.