Last Comment Bug 407748 - Ubuntu 7.10 Crash report submission failed: problem with the SSL CA cert
: Ubuntu 7.10 Crash report submission failed: problem with the SSL CA cert
Status: RESOLVED INVALID
:
Product: Toolkit
Classification: Components
Component: Breakpad Integration (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 437536 452963 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 08:45 PST by Kevin Brosnan
Modified: 2014-04-09 03:48 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Kevin Brosnan 2007-12-10 08:45:43 PST
1. Crash Firefox
2. crash bang boom dialog comes up
3. error dialog appears saying the crash report could not be sent

Submit.log: Crash report submission failed: problem with the SSL CA cert (path? access rights?)

ted said to investigate libcurl's handling of https://crash-reports.mozilla.com/submit.
Comment 1 Kevin Brosnan 2007-12-10 12:00:08 PST
curl https://crash-reports.mozilla.com/submit
curl: (77) error setting certificate verify locations:
CAfile: /etc/ssl/certs/ca-certificates.crt
CApath: none
Comment 2 Kevin Brosnan 2007-12-10 12:20:14 PST
curl error 77 is problem with the SSL CA cert (path? access rights?) and the file /etc/ssl/certs/ca-certificates.crt does not exist.

Comment 3 Ted Mielczarek [:ted.mielczarek] 2007-12-10 12:21:42 PST
FWIW, this curl command works just fine on Ubuntu 7.04, so I think this is a bug in Ubuntu.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2007-12-12 07:52:20 PST
sudo apt-get install ca-certificates

Dunno why that doesn't get installed as a dependency of openssl, given that SSL is pretty useless on the web without those certs, but you can file that upstream.
Comment 5 Reed Loden [:reed] (use needinfo?) 2008-03-06 01:52:01 PST
ca-certificates is now a dependency for firefox-3.0 on Ubuntu:
http://bazaar.launchpad.net/~mozillateam/firefox/firefox-3.0.head/revision/194
Comment 6 Fabien Tassin 2008-03-06 02:18:23 PST
Sorry, I've removed that. It's not a problem with Ubuntu firefox build after all.
It's more of an issue with the curl package.
Comment 7 Ted Mielczarek [:ted.mielczarek] 2008-03-06 04:03:44 PST
Yeah, it doesn't make sense for the Ubuntu package, as they're unlikely to use our crash reporting. It's only a problem for running official builds on Ubuntu, so fixing it in libcurl/openssl would make sense.
Comment 8 Jerod Lycett 2008-06-04 21:28:17 PDT
This problem occurs on 8.04 also, I use mozilla's release of FF not Ubuntu's so the dependency thing doesn't affect me so I had to install it by hand.
Comment 9 timeless 2008-06-05 02:29:32 PDT
right, the problem is that ubuntu's libcurl/openssl should depend on ca-certificates, and it doesn't. this is a bug that should be filed against ubuntu.

all we could do is write ubuntu specific system requirements "you need ca-certificates to use the crash reporter", which seems kinda pointless.

another way of writing it is: "your system needs to work before you can browse the web".
Comment 10 Dori 2008-06-06 23:36:26 PDT
*** Bug 437536 has been marked as a duplicate of this bug. ***
Comment 11 Kevin Brosnan 2009-07-07 07:06:08 PDT
*** Bug 452963 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.