Closed Bug 407798 Opened 14 years ago Closed 14 years ago

All tasks shown multiple times

Categories

(Calendar :: Tasks, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aryx, Assigned: sebo.moz)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/20071210 Calendar/0.8pre

In the task list, every task is shown as often as active storage calendars exist (= 15 times). The tasks are in the storage calendars. Was not able to reproduce in a clean profile.
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.12pre) Gecko/2007121012 Calendar/0.8pre.

Steps to reproduce:
1. Start Sunbird with clean profile
2. Create a task without start and due date in the default storage calendar
3. Create a second storage calendar

Actual results:
Previously created task is shown twice in the task list.
Duplicate of this bug: 407799
Works with Lt 2007121000
Fails with Lt 2007121005
Keywords: regression
Flags: blocking-calendar0.8?
(In reply to comment #3)
> Works with Lt 2007121000
> Fails with Lt 2007121005

The regression range implies this bug could be caused by the patch from bug 405459.
My fault, sorry about that. The solution is clear (one bracket missing). I will create a patch as soon as possible.
Attached patch correct bracketsSplinter Review
Assignee: nobody → sebo.moz
Status: NEW → ASSIGNED
Attachment #292498 - Flags: review?(daniel.boelzle)
Comment on attachment 292498 [details] [diff] [review]
correct brackets

oh yes, r=dbo
Attachment #292498 - Flags: review?(daniel.boelzle) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Flags: blocking-calendar0.8?
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Version: Mozilla 1.8 Branch → unspecified
Verified with Lt 2007121108
Status: RESOLVED → VERIFIED
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.12pre) Gecko/2007121105 Calendar/0.8pre.
You need to log in before you can comment on or make changes to this bug.