If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

rewrite "Organize Bookmarks", add "Show All History…", remove "Show in Sidebar" entry in menu reference

VERIFIED FIXED

Status

support.mozilla.org
Knowledge Base Articles
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Masahiro YAMADA, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007121009 Firefox/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007121009 Firefox/3.0b2pre

In, Current help document of Firefox Trunk (Minefield),
Document about "Organize Bookmarks…" is :
-------- quoted from help begin ------
Displays the Bookmarks Manager, a window where you can modify your
    bookmarks. You can sort, rename and change the properties for your
    bookmarks as well as add, remove, and move them.
-------- quoted from help end------
But, Now Bookmarks Manager is renamed to "Library"
So, It is needed to fix help documentation.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
See Also Bug 397411
Summary: Document about "Organize Bookmarks…" should be because of Bug 397411 → Document about "Organize Bookmarks…" should fixed because of Bug 397411

Comment 2

10 years ago
The Places Organizer, which has just been renamed to "Library", does much more than the old bookmarks manager, like including history.

We need to
- rewrite Bookmarks > "Organize Bookmarks…", now called "Show All Bookmarks…",
- add History > "Show All History…", and
- remove the History > "Show in Sidebar" in the menu reference.
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Document about "Organize Bookmarks…" should fixed because of Bug 397411 → rewrite "Organize Bookmarks", add "Show All History…", remove "Show in Sidebar" entry in menu reference
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk

Comment 3

10 years ago
But "Show all" does not accurately describe what all that dialog box does.  For example, "Import Bookmarks" doesn't logically fit under a heading titled "Show all".   It needs to go back to organize, or even better, "Manage"

Comment 4

10 years ago
That would be bug 404084. This bug is about updating Help documentation.

Comment 5

9 years ago
Moving over to sumo...
Component: Help Documentation → Knowledge Base Articles
Product: Firefox → Sumo
QA Contact: help.documentation → kb-articles
Target Milestone: Firefox 3 → ---
Version: Trunk → unspecified

Comment 6

9 years ago
... where this has been fixed already.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.