Filters keying on "Sender" header fail during download - eat the CPU on manual

RESOLVED DUPLICATE of bug 404489

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 404489
10 years ago
8 years ago

People

(Reporter: David A. Cobb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8) Gecko/2007100620 GranParadiso/3.0a8
Build Identifier: nightly/2007-12-10-03-trunk

SIMILAR TO SEAMONKEY Bug#404489
Those filters which specify 'sender ends-in "<X>" OR sender is "X"' fail to operate.
If I attempt to run the filter manually, the program uses all the cpu and I need to hit the power button to get the system's attention.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Did you mean From ends-in and From is? That's wfm for me on trunk.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Did you mean From ends-in and From is? That's wfm for me on trunk.
> 
Umm, No, Magus. Had I meand "From ..." I would have written "From ..."

Having said that, I must also say that the problem isn't that simple.  Not every one of my "Sender is" filters fail. On the other hand, all of the failing filters appear to be "Sender is".  Clearly, I need to investigate further.
(Reporter)

Comment 3

10 years ago
Created attachment 294569 [details]
TEXT containing example email that fails, plus msgRules stanza that doesn't find it

The attached file includes a recent e-mail, contents clipped, that failed to filter.  Also, the stanza from msgFilterRules.dat which describes the failing filter.

In addition, please note, SEARCH MESSAGES with the same criteria also fails to find the message
I've changed Bug 404489 to "Core" bug. Duping to Bug 404489.

> If I attempt to run the filter manually, the program uses all the cpu
> and I need to hit the power button to get the system's attention.

I couldn't see such behaviour with Thunderbird trunk(2007/12/19 build, MS Win-XP).
Does the "use of all CPU" always occur? Even with new profile?
Occurs with today's latest-trunk?
 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404489
You need to log in before you can comment on or make changes to this bug.