browser.urlbar.clickSelectsAll causes next character entered to be selected

RESOLVED DUPLICATE of bug 406360

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 406360
11 years ago
11 years ago

People

(Reporter: Aaron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007121108 Minefield/3.0b2pre Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007121108 Minefield/3.0b2pre Firefox/3.0

If browser.urlbar.clickSelectsAll is set to true, clicking on the urlbar selects the whole URL, as it should. The problem is that after it is selected, if you start typing the first character that you type is then selected and whatever the second character you type is will overwrite it. Whenever typing in a URL or a search term, the first character is always missing.

Reproducible: Always

Steps to Reproduce:
1. in about:config set browser.urlbar.clickSelectsAll to true
2. click in urlbar
3. type 1 character
4. type another character
Actual Results:  
the second character overwrites the first one, so only the second one appears.

Expected Results:  
the second character appears after the first character.
(Reporter)

Comment 1

11 years ago
This seems to be fixed in the latest nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 406360
You need to log in before you can comment on or make changes to this bug.