Address stays highlighted even when focus is no longer there.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: Jamie, Unassigned)

Tracking

({helpwanted, polish, qawanted})

unspecified
x86
Windows XP
helpwanted, polish, qawanted
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [see comment #6 for StR], URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

It happens quite often when I go to the start page(firefox's google) when I click once in the address bar(usually near the bottom) the address highlights, but when I type it's typing in the google search as seen in the screen shot.

Reproducible: Sometimes

Steps to Reproduce:
1.Open Firefox
2.Click in address bar
3.Start typing
4.Hope it happens?
Actual Results:  
You should see text in the google searchbox but you are trying to type a URL

Expected Results:  
Replaced the highlighted text with the stuff you just typed
(Reporter)

Comment 1

11 years ago
Created attachment 292758 [details]
Error in action

Bug in action
Maybe related to bug 407852?
Do you know when this started to happen?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121222 Minefield/3.0b3pre

I tried this about 5 times but couldn't reproduce it. Can you try the latest trunk nightly build? http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 4

11 years ago
i'll try the latest nightly build but as I said when I try to reproduce it it doesn't want to; it's usually when I open the browser click address bar and start typing, might be related to loss of focus, dunno.

Comment 5

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011904

Still can't reproduce this reliably, but it sure happens quite often.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

11 years ago
Tentative steps to reproduce:
1. Focus the location bar (Ctrl+L), enter google and hit Ctrl+Enter
2. Exit Firefox and open it anew
3. Focus the location bar and enter yyy (anything not triggering the autocomplete popup)
4. Open a new tab (Ctrl+T), enter google and hit Ctrl+Enter
5. Focus the location bar (Ctrl+L), enter google and hit Ctrl+Enter
6. Close the tab (Ctrl+W) and try to move the focus out of the location bar...

These steps work to about 80%, so you might have to try two or three times before succeeding.

Note: This doesn't work when www.google.com isn't suggested in the autocomplete popup at steps 4 or 5.

Might be an interaction of Google's homepage moving the focus to the search field, the (new) autocomplete popup claiming focus and the address bar grabbing the focus when the tab is closed while maybe at the same time the tabbrowser tries to move the focus to the content area when the tab is closed. I'll leave that to the experts...
Keywords: qawanted

Updated

11 years ago
Flags: blocking-firefox3?
Whiteboard: [see comment #6 for StR]

Comment 7

11 years ago
Observing commandDispatcher's focusedElement, it seems to be possible for #urlbar to get the focus without it being immediately forwarded to its html:input. When the focus is moved elsewhere, the html:input then doesn't seem to get informed about the blur and somehow stays half-focused.
Keywords: helpwanted
(Reporter)

Comment 8

11 years ago
guess it's something the developers forgot...Then again as a fellow programmer I understand(especially with the complexity of the application) that sometimes there's situations that we did not think of. That's why we test ;) we are all human after all 
Yeah, I've seen this happen before and I think it's because the page grabs focus and we put it back or something. Not gonna block, but adding to the wanted and polish list.

Feel free to renom if it starts happening all the time.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Keywords: polish

Comment 10

7 years ago
Jamie, is this problem gone for you?
comment 6 WFM.
Whiteboard: [see comment #6 for StR] → [closeme 2011-11-05][see comment #6 for StR]

Comment 11

6 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2011-11-05][see comment #6 for StR] → [see comment #6 for StR]
You need to log in before you can comment on or make changes to this bug.