Filter Enhancement Suggestion - Merging Filter

RESOLVED DUPLICATE of bug 169256

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 169256
11 years ago
7 years ago

People

(Reporter: Chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: version 2.0.0.9 (20071031)

Say I'm in college and am filtering all my teachers' emails to one folder.  If I am making a filter from a new teacher's email, it creates a filter for just that single email ('Create Filter from Message' option). 

It would be nice if I could add the new 'rule' into an existing filter to keep it more organized.  So instead of just displaying a new filter window, allow the option to add that rule to an existing filter.

If there seems to be an interest in this then I'd be willing to spend some time looking at this.





2)
It would also be useful to be able merge/split existing filters. 

Reproducible: Always

Steps to Reproduce:
N/A
Actual Results:  
N/A

Expected Results:  
N/A

N/A
(Reporter)

Comment 1

11 years ago
Please ignore this section.   I had too many spaces and did not see I left this included.  While I think a Merge/Split of filters could be useful, that's really a separate issue from adding to an existing filter.

> 2)
> It would also be useful to be able merge/split existing filters. 

Comment 2

11 years ago
I think the UI for 1) would be challenging... but 2) - the merge part - sounds fairly straight forward and probably useful IMO. (Bug 348848 would be the split part I think.)
(Reporter)

Updated

11 years ago
Summary: Filter Enhancement Suggestion - Adding new rule to An Existing Filter → Filter Enhancement Suggestion - Merging Filter
(Reporter)

Comment 3

11 years ago
I didn't think of that but '1)' could easily be accomplished by implementing '2)'.  It would simply be a matter of merging the relevant filters.  That would avoid UI concerns by avoiding making the initial creation of a filter too complicated.  

I agree that <a href="show_bug.cgi?id=348848" title="NEW - New Duplicate Filter button (copy filter) would be nice">Bug 348848</a> is the split.  I changed the title of the bug to "Filter Enhancement Suggestion - Merging Filter" to reflect that.  While they do go together, they are separate issues.

Comment 4

11 years ago
Chris, your first item is bug 169256 

Comment 5

7 years ago
So is this going to be transformed to the "Merge filter" request?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: unspecified → Trunk

Comment 6

7 years ago
yup, i think bug 169256  is all that is left
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 169256
You need to log in before you can comment on or make changes to this bug.