unable to select an unfiled bookmark or a bookmark from my toolbar as my home page in prefs

VERIFIED FIXED in Firefox 3 beta5

Status

()

P2
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: moco, Assigned: mano)

Tracking

({regression})

Trunk
Firefox 3 beta5
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

unable to select an unfiled bookmark or a bookmark from my toolbar as my home page in prefs

we appear to be rooting in place:folder=2&excludeQueries=1

see http://lxr.mozilla.org/seamonkey/source/browser/components/preferences/selectBookmark.xul#28

note, we may also want to take this change to stop hard coding the folder id of 2, see bug #399264
should root that query with "All Bookmarks" folder, as we do for the sidebar:

http://mxr.mozilla.org/seamonkey/source/browser/components/places/content/bookmarksPanel.js#38
No longer blocks: 399264
Depends on: 399264
drivers: regression from firefox 2 due to being unable to select bookmarks from the toolbar for your homepage from the prefs UI.
Flags: blocking-firefox3?
Keywords: regression
Priority: -- → P2
Target Milestone: --- → Firefox 3 beta4
Assignee: nobody → mano
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: Firefox 3 beta4 → Firefox 3
Attachment #309359 - Flags: review?(dietrich) → review+
mozilla/browser/components/preferences/selectBookmark.js 1.9
mozilla/browser/components/preferences/selectBookmark.xul, 1.8
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 3 → Firefox 3 beta5

Comment 5

11 years ago
verified with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.