font gets reset after inserting bullets or pasting image

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
10 years ago
9 years ago

People

(Reporter: Don Feliciano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Firefox/2.0.0.11
Build Identifier: 2.0.0.9

When composing an HTML message, the selected font is changed to "Variable Width" after inserting a bulleted list, or after pasting an image from the clipboard. It's pretty annoying b/c the composition window doesn't display the font differently - it *looks* like your still composing with your desired font, but in fact it was reset. The only indicator is the font selection drop-down.

Steps to re-create:

* Set preferences so that default composition format is HTML
* Set default font to something (like Verdana/small)
* Compose new HTML message
* Type some text
* Click toolbar button to insert bullets
* Type some more text, end the list, more text, etc.

All of the text added from the bullets onward is reset to "Variable Width." If your display font is the same as your default composition font, and I'd guess for most it is, you won't have much in the way of a visual indicator that things changed; only the font selection drop-down changes. The result when an Outlook user reads your mail (assuming my example of Verdana/small)? The intro to your mail is Verdana, 10pt, and the bulleted list and all that follows is Times 12pt.

Using an HTML template does not help

Reproducible: Always

Steps to Reproduce:
* Set preferences so that default composition format is HTML
* Set default font to something (like Verdana/small)
* Compose new HTML message
* Type some text
* Click toolbar button to insert bullets
* Type some more text, end the list, more text, etc.
Actual Results:  
All of the text added from the bullets onward is reset to "Variable Width."  The only indicator that the font changed is the font selection drop-down.

Expected Results:  
Selected font face should be retained.

My font settings in prefs.js:

user_pref("font.default.x-western", "sans-serif");
user_pref("font.minimum-size.x-western", 12);
user_pref("font.name.sans-serif.x-western", "Verdana");
user_pref("font.size.variable.x-western", 12);
user_pref("msgcompose.font_face", "Verdana");
user_pref("msgcompose.font_size", "small");

Comment 1

9 years ago
Actually, for me, the font change shows up immediately in the UI. I enter everything in Arial, and as soon as I click the bullet button, it changes in the selection list and in my typed text to variable width AND the next size larger.

Comment 2

9 years ago
This seems to be the same problem as reported here:
https://bugzilla.mozilla.org/show_bug.cgi?id=435400

Comment 3

9 years ago
Is there any workaround for this bug, other than to laboriously reset the fonts after text has been entered in bullets? I often send group emails that need to have consistent font display, and I find this font-resetting to be quite time consuming and tedious. Please let me know if there is some way to patch this in the current build. Thanks.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.