atob() function throws non-correct failure code

RESOLVED DUPLICATE of bug 287112

Status

()

--
trivial
RESOLVED DUPLICATE of bug 287112
11 years ago
11 years ago

People

(Reporter: telega, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Javascript function atob() when applied to incorrect string, like atob("\r\n") throws an exception with NS_ERROR_OUT_OF_MEMORY failure code.

Reproducible: Always

Steps to Reproduce:
1.Open sample html page:
<script>
try {
  atob("\r\n");
}
catch(e) { alert(e); }
</script>
2.See alert box with NS_ERROR_OUT_OF_MEMORY failure code.
Actual Results:  
An exception with NS_ERROR_OUT_OF_MEMORY failure code is thrown

Expected Results:  
Failure code should be different, because error is caused by incorrect input string, not lack of memory.
(Reporter)

Updated

11 years ago
Component: Extension Compatibility → General

Comment 1

11 years ago
duplicate of bug 287112

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 287112
QA Contact: extension.compatibility → general
You need to log in before you can comment on or make changes to this bug.