Closed Bug 408176 Opened 12 years ago Closed 12 years ago

autocomplete conflicts with window keybord events

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 286933

People

(Reporter: cenopelepi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Hi,
so the problem:
If you have web form with simple INPUT with autocomplete="on" and global event handler for page like onkeypressed, for Enter key there is conflict that is not happening in IE.


Reproducible: Always

Steps to Reproduce:
1. Enter some values in INPUT type="text" field like ('a', 'abc', 'abcd') so autocomplete works.
2. Now delete from that field and start typing like 'ab'.
3. Autocomplete drop down shows up and you go with list using up/down arrow, and then select it by pressing Enter.
4. Whole page got event handler like onkeypress ,if key="enter" submit() or something similar :-)
5. As you press Enter from autocomplete drop down event onkeypress is called.
Actual Results:  
1. window onkeypress is called
2. value in text field in request is etc. 'ab' and not 'abcd', as i selected using autocomplete dropdown

Expected Results:  
1. on autocomplete dropdown, onkeypress event should not be could.
2. when you select value using Enter, then next Enter press should call onkeypress

<html>
<body onkeydown="if(e.wich==13)alert(1);return true;">
<input type="text">bla</input>
</body>
</html>
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286933
You need to log in before you can comment on or make changes to this bug.