Check spelling button should display selected dictionary language

RESOLVED DUPLICATE of bug 491055

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 491055
11 years ago
3 years ago

People

(Reporter: Fabio Varesano, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 BonEcho/2.0.0.11
Build Identifier: version 2.0.0.9 (20071115)

The button which enable check spelling and spelling as you type should display the currently selected language.

Currently you have to click on the bottom arrow to understand which language is selected.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Confirming RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Updated

7 years ago
Summary: Check spelling bottom should display selected dictionary language → Check spelling button should display selected dictionary language
Blocks: 905097
No longer blocks: 905097
Keywords: uiwanted
This was confirmed by Magnus in comment 1 without reasons or indication of deep consideration; but he has since changed his mind per Bug 368915 Comment 132. I also have doubts -> unconfirmed

Given that in the current simple editor design where the whole text can only be spell-checked in one and the same language, there's not much benefit of showing the "current" language because user can change that maximally once and thereafter it will always be the same.
Status: NEW → UNCONFIRMED
Ever confirmed: false
In bug 368915 a new "language" button was proposed to allow easy language switching and to show the currently selected language. This is how it looks: attachment 8625069 [details].
If the reporter of this bug here is still interested in the feature, he should lobby it over in the other bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(fabio.varesano)
No need for two bugs with the same wish for an enhancement. The other bug 491055 is more comprehensive, so therefore this becomes a duplicate of the more recent bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(fabio.varesano)
Resolution: --- → DUPLICATE
Duplicate of bug: 491055
You need to log in before you can comment on or make changes to this bug.