Closed Bug 408209 Opened 15 years ago Closed 2 months ago

Add a "Download more dictionaries..." menu to language dropdown menu of spelling check button

Categories

(Thunderbird :: Message Compose Window, enhancement)

enhancement
Not set
normal

Tracking

(thunderbird102 verified)

RESOLVED FIXED
102 Branch
Tracking Status
thunderbird102 --- verified

People

(Reporter: fabio.varesano, Assigned: freaktechnik)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 BonEcho/2.0.0.11
Build Identifier: version 2.0.0.9 (20071115)

Would be useful having a "Get other languages" link in the menu which popups on the dictionary language selection menu. 

The same approach has been implemented in other areas of the mozzilla apps and I think it surely helps the users

Reproducible: Always
OS: Linux → All
also see bug 476623
and bug 69687
Depends on: 728775
Blocks: 491055
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 408207
Summary: spell checker button menu should display a "get other languages" link → Add a "Download more dictionaries..." menu to language dropdown menu of spelling check button
Assignee: nobody → martin
Status: NEW → ASSIGNED
Target Milestone: --- → 102 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9b37e10d7898
Show get more dictionaries menuitem in composer selector. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

I see "Add Dictionaries..." in the En-US version.

Clicking on it opens the AOM to the Dictionaries & Language Packs page.

Status: RESOLVED → VERIFIED

Sorry, I've backed this out, as it's made a big mess of mail/test/browser/composition/browser_focus.js.

Backout:
https://hg.mozilla.org/comm-central/rev/449e3764e2117c22abaae7c03c9e858aef965a87

Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1320571fd661
Show get more dictionaries menuitem in composer selector. r=mkmelin

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED

comm/mail/test/browser/composition/browser_spelling.js seems to be failing

Flags: needinfo?(martin)

Ugh, I didn't look close enough when I checked that test :/

Flags: needinfo?(martin)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/138dd2747ebe
followup: fix expectations in spelling test. r=#thunderbird-reviewers,mkmelin

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.