Closed Bug 408254 Opened 12 years ago Closed 12 years ago

MAPINFO:LINES not recognized using MSC 1500 (LNK1117 error)

Categories

(Firefox Build System :: General, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 401140

People

(Reporter: demomaker, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121319 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121319 SeaMonkey/2.0a1pre

linker option MAPINFO:LINES not recognized by msc 1500 , gives LNK 1117
replacing this link option with mapinfo:exports seems to be fine with msc 1500


Reproducible: Always

Steps to Reproduce:
1. launch the build using vs9
2.
3.
Actual Results:  
error LNK 1117

Expected Results:  
success
using msc 1400 
LINK : warning LNK4224: /MAPINFO:LINES is no longer supported;  ignored
using msc 1500
LINK gives LNK1117 error
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: MAPINFO:LINES not recognized using MSC 1500 → MAPINFO:LINES not recognized using MSC 1500 (LNK1117 error)
Version: unspecified → Trunk
Duplicate of this bug: 412581
I tried to change the build config to link with mapinfo:exports but this results in a non-working executable for xulrunner.exe. Does anybody know how to build a working debug copy with this version of MSVC?
Bug 401140 removed the MAPINFO:LINES switch from the build process. Can you pull a fresh tree from CVS and see if this works for you now?
(In reply to comment #4)
> Bug 401140 removed the MAPINFO:LINES switch from the build process. Can you
> pull a fresh tree from CVS and see if this works for you now?

I succeeded to build with latest tree!

Marking as dup to bug 401140.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: vc9-zlib
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.