Focus bug involving two pages, one of which contains a plugin (OS X)

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: smichaud, Assigned: smichaud)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

11 years ago
If the saved browser state contains two pages, the topmost of which
loads at least one plugin, it won't be possible to put the keyboard
focus into any of the top window's text fields when you restart the
browser.

Steps to reproduce:

1) Run a recent Minefield nightly and open two windows.

2) Load a URL into one of them that contains at least one plugin
   (http://www.rogerdean.com/ will do -- it loads one Flash object).
   The other window can have any contents, including about:blank.

3) Click on the page containing the plugin to make it the topmost.

4) Quit the browser, and choose "Save and Quit" (the default) when it
   asks you if you want to save your tabs and windows.

5) Restart the browser, and wait until both pages are fully loaded --
   the page containing the plugin should once again be topmost.

6) Click on any of the topmost window's text fields outside the plugin
   (e.g. the location bar or the Google search box) -- you won't see a
   flashing text-entry cursor, and it won't be possible to enter text.

I also tried this with a Java object and one of Apple's QuickTime
movie trailers, with the same results:

http://java.sun.com/applets/jdk/1.4/demo/applets/Clock/example1.html
http://www.apple.com/trailers

By the way, my patch for bug 403232 (attachment 290893 [details] [diff] [review]) also fixes
this bug.  The following tryserver build was built with that patch:

https://build.mozilla.org/tryserver-builds/2007-11-29_13:05-smichaud@pobox.com-focus/
Flags: blocking1.9?
(Assignee)

Updated

11 years ago
Assignee: joshmoz → smichaud
Summary: Focus bug involving two pages, one of which contains a plugin → Focus bug involving two pages, one of which contains a plugin (OS X)

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
(Assignee)

Comment 1

11 years ago
By the way, I also tested for this problem (using today's Minefield
nightlies) on Windows and Linux ... and didn't see it.
Flags: blocking1.9+ → blocking1.9?
Priority: P2 → --
(Assignee)

Comment 2

11 years ago
Silly bugzilla.  I didn't mean to remove the blocking1.9+ flag.
Ok.  Setting back to blocking+.  Also, set to P2.  Steven, please make sure the priority matches the other focus issues.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
(Assignee)

Comment 4

11 years ago
> Steven, please make sure the priority matches the other focus
> issues.

It does -- they're all blocking1.9+ and P2.
(Assignee)

Updated

11 years ago
Depends on: 403232
(Assignee)

Comment 5

11 years ago
Fixed by patch for bug 403232, which just landed on trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-litmus?
(Assignee)

Comment 6

11 years ago
(Following up comment #5)

The first time I landed a patch for bug 403232, I had to back it out
because of Mochitest failures.  I've just landed another version of
the patch, which had no problems.
in-litmus+:

https://litmus.mozilla.org/show_test.cgi?id=5314

(Steven, comment 0's testcase made it a breeze to transplant this into Litmus; thanks!)
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.