NavQuirks: table background does not extend into padding

VERIFIED WONTFIX

Status

()

P3
normal
VERIFIED WONTFIX
19 years ago
18 years ago

People

(Reporter: gpf1024, Assigned: karnaze)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    2000052708

table padding should have color specified in 'background', but instead it is 
transparent and has the color of the parent block object. take a look at 
www.gremlinsoft.com/mozilla.html for an example of this.

Reproducible: Always
Steps to Reproduce:
1. go to www.gremlinsoft.com/mozilla.html


<STYLE>
BODY
{
    BACKGROUND: gray
}
TABLE
{
    BACKGROUND: white;
    BORDER: black 1px solid;
    PADDING: 25px;
}
</STYLE>
Changing to HTMLTables.  Perhaps this is why neither CSS table model allows /
describes padding on tables...

But it looks like it works fine in the linux build 2000-05-28-09-M16, so not
confirming.  The padding is definitely white.  What do you see?
Assignee: pierre → karnaze
Component: Style System → HTMLTables

Comment 2

19 years ago
Stan could you next time attach your html-file (may be including the  style
section to the bug, as I remmeber that I have seen the same URL on a bug 2 days
ago. I closed that bug, because it has worked perfectly in strict mode. So does
this bug. I am not sure how the behavior in Nav-Quirks Mode should look like and
a little bit in hurry.

Comment 3

19 years ago
Created attachment 9318 [details]
testcase in strict mode
(Reporter)

Comment 4

19 years ago
Created attachment 9319 [details]
Transitional test case
(Reporter)

Comment 5

19 years ago
It works fine in STRICT mode.  In transitional it does what the original 
description says it does.  I'm not sure if it is supposed to do that or not.  I 
guess originally I tried it in Transitional mode and it didn't behave the way 
the spec said it should.  So the bug (if it is a bug afterall) applies only to 
Transitional mode.
Confirming and retitling.

What happens with background images?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: table padding does not use color specified in 'background' style. → NavQuirks: table background does not extend into padding
(Assignee)

Comment 7

19 years ago
In transitional mode, backgrounds on tables show up in the cells. But Nav 
apparantly has a bug where padding on the table inherits into the cells (try 
adding another cell to attachment #2 [details] [diff] [review]). We are not going to add that additional 
quirk. 

Since Strict mode doesn't have the problem I'm marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX

Comment 8

18 years ago
Verified WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.