The Page Info View Certificates label has the "v" character underlined as an access key

RESOLVED FIXED in Firefox 3 beta3

Status

()

Firefox
Page Info Window
--
minor
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Away for a while, Assigned: Away for a while)

Tracking

({access, polish})

Trunk
Firefox 3 beta3
access, polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

10 years ago
Created attachment 293119 [details]
Screenshot

Please see the attached screenshot.  Since the View Certificates is a button with an access key, the access key on the label is redundant.  This is caused because a XUL <label> control is used for this label, which obtains the access key from its "control" attribute, if provided.  I'll be posting a patch shortly.
(Assignee)

Updated

10 years ago
Target Milestone: --- → Firefox 3 M11
(Assignee)

Comment 1

10 years ago
Created attachment 293120 [details] [diff] [review]
Patch (v1)

Trivial patch to switch the <label> control with a <description> control.
Attachment #293120 - Flags: review?(mano)
This seems wrong... what's the purpose of setting the control attribute there anyway? should we just use labelledby?

Comment 3

10 years ago
FWIW, the a11y module makes use of <description control="[id]"> where a description is associated with a specific control or container (groupbox etc.)

Descriptions are secondary information associated with a control or a container that are important to understanding it. Most static text in a dialog should be either a label or a description.

Comment 4

10 years ago
For this bug, I'm not sure what this text gets set to, but here's an example of a description for a button in Firefox:

Tools -> Options -> Main ->

--  Add-ons ---------------------------------------------------------

Change options for your add-ons               [_M_anage add-ons]

---------------------------------------------------------------------


The description for the button is "Change options for your add-ons". By associating it with the button it means that text will be read when the button gets focused.
(Assignee)

Comment 5

10 years ago
Comment on attachment 293120 [details] [diff] [review]
Patch (v1)

Here is what the static text and button look like:

This web site provides a certificate to verify its identity   [_V_iew Certificate]

I'm asking for Aaron's review on whether he thinks a <description control=...> is appropriate for this control.  I think it is, based on Aaron's comments.  I'm ask for Mano's review once again if Aaron's review is positive.
Attachment #293120 - Flags: review?(aaronleventhal)
Aaron: is it by design that accesskeys are set for labels but not for descriptions when the control attribute is used? Is the control attribute still honored at all in this case?

Comment 7

10 years ago
Comment on attachment 293120 [details] [diff] [review]
Patch (v1)

Yes, that's exactly what <description control> is for.
Attachment #293120 - Flags: review?(aaronleventhal) → review+

Comment 8

10 years ago
Mano, yes that's by design. The control attribute for description only affects screen reader usage -- it makes the description get spoken when the control gets focused. Exact behavior on when it's spoken depends on the particular screen reader and the user's verbosity settings.
(Assignee)

Comment 9

10 years ago
Comment on attachment 293120 [details] [diff] [review]
Patch (v1)

Requesting code review again based on Aaron's r+...
Attachment #293120 - Flags: review- → review?(mano)
Comment on attachment 293120 [details] [diff] [review]
Patch (v1)

r=mano, thanks.
Attachment #293120 - Flags: review?(mano)
Attachment #293120 - Flags: review+
Attachment #293120 - Flags: approval1.9?
Comment on attachment 293120 [details] [diff] [review]
Patch (v1)

a=mconnor on behalf of drivers
Attachment #293120 - Flags: approval1.9? → approval1.9+
mozilla/browser/base/content/pageinfo/pageInfo.xul 1.13
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.