Closed Bug 408357 Opened 13 years ago Closed 13 years ago

Error when the invite command is used in Private Chat.

Categories

(Other Applications :: ChatZilla, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Mitch, Assigned: Gijs)

Details

(Whiteboard: [cz-0.9.80])

Attachments

(1 file)

3.29 KB, patch
bugzilla-mozilla-20000923
: review+
Details | Diff | Splinter Review
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: ChatZilla 0.9.79-2007121222

When in a private chat, using /invite with any single parameter causes an error, instead of giving a friendly warning.

Reproducible: Always

Steps to Reproduce:
1. Open a private chat
2. Use /invite with exactly one parameter.
Actual Results:  
[ERROR]	Internal error dispatching command “invite”.
[ERROR]	TypeError: channel has no properties @ <chrome://chatzilla/content/commands.js> 3119

Expected Results:  
A friendly warning should have been given, stating that the command cannot be used within that context.
Attached patch PatchSplinter Review
I'll recommend myself for suggestions on naming that string without having to re-align all those = signs while becoming a bit more informative. Other than that, r? -> Silver
Assignee: rginda → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #293126 - Flags: review?(silver)
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Attachment #293126 - Flags: review?(silver) → review+
Checking in mozilla/extensions/irc/locales/en-US/chrome/chatzilla.properties;
/cvsroot/mozilla/extensions/irc/locales/en-US/chrome/chatzilla.properties,v  <--  chatzilla.properties
new revision: 1.148; previous revision: 1.147
done
Checking in mozilla/extensions/irc/xul/content/commands.js;
/cvsroot/mozilla/extensions/irc/xul/content/commands.js,v  <--  commands.js
new revision: 1.137; previous revision: 1.136
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.80]
You need to log in before you can comment on or make changes to this bug.