Closed Bug 408378 Opened 12 years ago Closed 12 years ago

js function retrieves an argument of type Number with window.setTimeout

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 10637

People

(Reporter: ginocochuyt, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL) AppleWebKit/523.12.9 (KHTML, like Gecko) Version/3.0 Safari/523.12.9
Build Identifier: 4.42.0.0

when calling a funtion with the setTimeout method -> the function retrieves an argument!

example:

function timedFN(x) { alert(x) };

window.setTimeout(timedFN, 10);

alert's a number which is (not sure!! but seems to be) the actual time from when setTimeout is called to the excecution of timedFN.

Reproducible: Always

Steps to Reproduce:
1.function timedFN(x) { alert(x) };  window.setTimeout(timedFN, 10);
2.in any HTML PHP.. page
3.
Actual Results:  
alert box with a number appears

Expected Results:  
alert box with undefined should come-up
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 10637
You need to log in before you can comment on or make changes to this bug.