If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scrollbar in a div does not get hidden when the div gets hidden

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Jeff Carney, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testcase, URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

A page creates divs that need to hide or be visible at the user's discretion. If the div contains or creates a scrollbar, the scrollbar should hide when the div hides. It does not. This is true for text areas and divs with overflow set to scroll or auto.

Reproducible: Always

Steps to Reproduce:
Visit the URL I indicated above. I wrote the page specifically to illustrate the problem. The steps below are written on the page.

TEST ONE. Click the 'Test 1' button to reveal the hidden div. The div contains a text area. Fill the text area with enough text to make a vertical scrollbar appear. You can also click the 'fill' button. Then click the 'hide' button to make the div disappear.

TEST TWO. The symptom will also manifest itself if you create a div with overflow set to auto. Click the 'Test 2' button to reveal div with no content except a couple of buttons. Add content ( a text input) by clicking the top button. Hide the div with the second button.


Actual Results:  
Scroll bar remains.

Expected Results:  
Scrollbar should have been hidden.

There are several work-arounds, so don't feel like you have to rescue me personally.
(Reporter)

Comment 1

10 years ago
Created attachment 293304 [details]
.html test case

Exact duplicate of the test URL I indicated in the bug report.
Could you please try with Firefox 3.0 Beta 1?
- http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0b1/
Whiteboard: testcase
Version: unspecified → 2.0 Branch
(Reporter)

Comment 3

10 years ago
Well, yeah, the bug is not in v 3.0 Beta 1. So I guess that's good.
Then this bug is WORKSFORME.
(The only fixes landing on the 2.0 branch are security, stability and regression fixes).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.