planet's cron needs a newer python version (2.5.x)

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: reed, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
So, I can't upgrade planet's code anymore due to the old python version that's running on mradm01 (since it's RHEL4). In order to upgrade planet's backend code and fix a few bugs that people have been encountering with it, I need for the cron to be run on a box with a newer python (2.5.x), so probably a RHEL5 box. There's a few other prerequisites that need to be installed for planet to run on a machine, but they are easy to add later. The biggest thing needed is the newer python version. :)

justdave mentioned that bugzilla is going to need a machine soon to run its crons so that recluse can be recycled for other things. Maybe what's needed is another box besides mradm01 that is running RHEL5 and can run cron jobs. I'll let you all work out the details. ;)
(Reporter)

Updated

10 years ago
Depends on: 408521
Assignee: server-ops → aravind
Assignee: aravind → justdave
This apparently won't run over NFS.  We moved the build directory to the local disk on mradm02 and it works fine from there (writing out the docroot over NFS to the master copy for the cluster).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.