Closed Bug 408563 Opened 14 years ago Closed 14 years ago

Download off about:cache crashes, makes system almost unresponsive

Categories

(Core :: Networking: Cache, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 421828

People

(Reporter: wenzel, Unassigned)

Details

Attachments

(1 file)

Build ID: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2007121504 Minefield/3.0b3pre

Downloading a medium-sized file off about:cache makes Minefield go majorly busy on hard drive and CPU, making the entire system almost completely unresponsive, until Minefield either crashes on its own or you manage to click "force quit".

Reproducible consistently, on an empty profile:
- go to a page that downloads a decently sized file onto the disk cache, for example: http://www.youtube.com/watch?v=H_MgzgykqKU (the Joey tutorial).
- click play, let it cache the file
- open another tab (or use this one), type about:cache, then click on disk cache
- search the page for "get_video" in order to find the item, size approx. 6.6 MB.
- right-click, save as, pick an arbitrary location, okay

Shortly thereafter the harddrive is intensively accessed and the entire system is hogged. If you manage to right-click the Minefield symbol in the dock and force-quit the application, it returns to normal.


Expected behavior is quite obvious: It should store the file where you wanted it to be, without much further ado.

If you need additional information, let me know.
Attached file result saved to disk
I just noticed that it actually did save something to disk after all. It is an XML file telling you the requested cache object was not available. Interesting.
Can somebody please confirm this? This is a consistently reproducible crashing bug even in the latest Minefield nightly, should this be blocking the Fx3 release?

As I just found out, this bug creates about a billion identical log entries in /var/log/system.log, each of which looks like this:

Feb 20 11:25:27 chronos [0x0-0xaf0af].org.mozilla.firefox[0]: firefox-bin(2017,0xa078cfa0) malloc: *** mmap(size=46141440) failed (error code=12)
Feb 20 11:25:27 chronos [0x0-0xaf0af].org.mozilla.firefox[0]: *** error: can't allocate region
Feb 20 11:25:27 chronos [0x0-0xaf0af].org.mozilla.firefox[0]: *** set a breakpoint in malloc_error_break to debug
This is the same bug as bug 421828.
Marking this one as a dupe, because 421828 is "wanted1.9.0.x".
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 421828
You need to log in before you can comment on or make changes to this bug.