Transparent area in pattern print-previews OK, but prints as white instead of the background color. Image is also squashed vertically.

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Lou Adams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

At the top of the web page at http://www.kokudzu.com/ is a leaf pattern produced by a GIF file.  The area around the leaves is transparent in the pattern so the background yellow color shows through.  In print preview (with background pattern print enabled) the background yellow is visible through the transparent areas, which is as it should be.  When printed the leaves are squashed vertically, and the transparent areas print as white instead of yellow.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.kokudzu.com/ to view the home page.
2. Do File/Page Setup and make sure "Print Background" is checked.
3. Do File/Print Preview.  Note that area around leaves at to of page is yellow.
4. Send to printer, or print to PDF if you have it.
Actual Results:  
Examine the print and note that the area around the leaves is white, and the leaves are squashed to fit inside the border of the title area.

Expected Results:  
The print should match the print preview: Yellow around the leaves, unsquashed leaves.

The white-print problem also occurs in IE 7, so the handling of transparent areas must be a general browser problem.

I am attaching images that illustrate the problem.  The images were created from screen captures, but the problem is seen on two printers made by two manufacturers.  The problem is also seen when the print output goes to a PDF creator.

I know of no workaround.
(Reporter)

Comment 1

11 years ago
Created attachment 293392 [details]
Print preview shows web page correctly.
(Reporter)

Comment 2

11 years ago
Created attachment 293393 [details]
Actual print shows white area around leaves, and squashed leaves.
(Reporter)

Comment 3

11 years ago
I am webmaster of this website, created the graphics, and programmed the web pages.   So I can answer any detailed questions about these details.

Comment 4

10 years ago
This seems to be fixed as I couldn't reproduce this anymore in FF 3 and SM 2
builds of the last months.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> This seems to be fixed as I couldn't reproduce this anymore in FF 3 and SM 2
> builds of the last months.

Christian:

I ran another test, and find that the problem still exists.  My version of Firefox is 2.0.0.13  I conducted the same test as in my original report, namely printing the home page of www.kokudzu.com

Lou
Tuesday Afternoon
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

10 years ago
Erm, if you used FF 2 for testing that's not surprising. As I wrote it's fixed in FF 3 and SM 2, i.e. Gecko 1.9, back in October 2007. It will never get fixed in older stuff like FF 2.
Please get a recent version like the Beta 4 of FF 3 (see http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0b4/win32/en-US/) and retest it.
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> Erm, if you used FF 2 for testing that's not surprising. As I wrote it's fixed
> in FF 3 and SM 2, i.e. Gecko 1.9, back in October 2007. It will never get fixed
> in older stuff like FF 2.
> Please get a recent version like the Beta 4 of FF 3 (see
> http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0b4/win32/en-US/)
> and retest it.

Christian:

Sorry.  I was under the impression that the purpose of Bugzilla was to report problems in current applications.

And I didn't know that FF 2 stood for Firefox 2.0.  I don't know what Erm or SM mean.

I'm just a user trying to help.  I'd rather not install a beta version of Firefox on my PC.  So this is my last message about this issue.  Set the completion status as you think appropriate.

Lou
Tuesday Afternoon

Comment 8

10 years ago
Sorry for using those acronyms, I thought they're commonly used - SM stands for SeaMonkey, the internet suite formerly known as Mozilla.
And yes, you're right in the purpose of Bugzilla and your input is valuable. However developers usually are free on when to fix bugs (at least non security related ones).
I think this one was fixed by switching to the Cairo graphics lib, a quite huge step not done in a maintainance release like 2.0.x.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.