provide a way to inform addon authors when there's a version one newer than theirs

VERIFIED WONTFIX

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
--
enhancement
VERIFIED WONTFIX
10 years ago
2 years ago

People

(Reporter: timeless, Unassigned)

Tracking

x86
Windows XP

Details

(Whiteboard: [ddn])

(Reporter)

Description

10 years ago
venkman used to be max version ff3.0b2. recently 3.0b3pre was added. It'd be nice if it'd be possible for owners to opt into receiving a notification when a version 1 greater than there formerly max version.

example:
global.maxversion:ff3.0b2
venkman.maxversion:ff3.0b2

set(global.maxversion,ff3.0b3pre)
venkman.maxversion:ff3.0b2
venkman.versionoutofdate:1
mail(venkman)

set(global.maxversion,ff3.0b3)
venkman.maxversion:ff3.0b2
venkman.versionoutofdate:2
nomail(venkman)

authors get only one notice, no matter how far behind they are. when they go to the page to update it, they would be responsible for updating to current if they want to be notified again, otherwise, when they update, they are aware they aren't current, and there's no need for amo to tell them later that they're less current.

presumably addons has multiple distinct "lines" (ff2, ff3) each with its own maxversion so that venkman could get a notice for both lines...

it might make more sense to send notices daily, so if 3 versions bump the same day, only one mail is sent per addon, instead of 3.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Depends on: 375719
Ever confirmed: true

Updated

10 years ago
Duplicate of this bug: 420932
Duplicate of this bug: 461697
Releases are announced in the RSS feeds in the developer hub.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Reopening, the developer hub provides much uninteresting information for people who just want to keep theirs mature add-ons' compatibilities in sync with the applications. So AMO should offer at least mail notifications:
- for new release maxVersions
- for feature frozen maxVersions (how is the naming policy here)
- for all other new maxVersions (all alphas, all betas)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Would tagging the developer Hub posts which refer to updated releases and using (eg) Yahoo pipes to construct a feed of only those posts be sufficient?
We could email authors if they opt in - another flag on their user profile.  -> [ddn] to come up with something.  If the pipes are good enough, that works too.
Whiteboard: [ddn]
Emailing add-on devs seems like it could reach more people more reliably, I suspect.
We're moving to a system of automatic compatibility upgrades this quarter.  That means if your add-on continues to work with Firefox you won't need to adjust this.  I'm sure more details will be forthcoming.

-> Wontfix on that basis.
Status: NEW → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → WONTFIX
Verifying.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.