Closed Bug 408612 Opened 14 years ago Closed 14 years ago

Installing Flashgot Extension leaks an nsGlobalWindow and more

Categories

(Core :: General, defect, P3)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: cbook, Assigned: sicking)

References

()

Details

(Keywords: memory-leak)

Attachments

(2 files)

Attached file leak log
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre)
Gecko/2007121517 Minefield/3.0b3pre

Steps to reproduce:
Installed Flashgot Extension https://addons.mozilla.org/en-US/firefox/addon/220 with Firefox restart
Firefox came up with Flashgot Welcome Page
Shutdown of Firefox
Leak

nsStringStats
 => mAllocCount:          37658
 => mReallocCount:         5631
 => mFreeCount:           36783  --  LEAKED 875 !!!
 => mShareCount:          40803
 => mAdoptCount:           7163
 => mAdoptFreeCount:       7156  --  LEAKED 7 !!!
Flags: blocking-firefox3?
Summary: Installing Flashgot Extension Leaks → Installing Flashgot Extension leaks an nsGlobalWindow and more
Please renom if there's a regression from Fx2.x branch ...
Flags: blocking-firefox3? → blocking-firefox3-
Flags: blocking-firefox3-
Product: Firefox → Core
QA Contact: general → general
Flags: blocking1.9?
Tomcat: do we leak just when flashgot is installed, or anytime afterwards when it is installed too?
Is this just a shutdown leak, or does it increase when you use more browser windows?  (Probably easier to tell with leak-gauge logs, which will also tell you which windows leaked -- e.g., if it was the about:blank hidden window.)

If it's a shutdown leak, bug 398219 might help here.
(In reply to comment #2)
> Tomcat: do we leak just when flashgot is installed, or anytime afterwards when
> it is installed too?
> 

its also afterwards when i have about:blank as homepage and not surfing or using other tabs. Created a new leak log.
+ing since Flashgot is a pretty common extension.  If this is just a shutdown leak we should minus
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Assignee: nobody → jonas
This looks like it could be a shutdown leak. Tomcat, it would be great if you could whack at this a bit more and see if you can get it to leak more than 2 nsGlobalWindow
Priority: P2 → P3
This is now fixed by bug 412491 and Version 1.2.9. Verified while using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012113 Minefield/3.0b3pre
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.