text overlaps down arrow in gtk dropdown boxes in RTL mode

RESOLVED DUPLICATE of bug 316748

Status

()

RESOLVED DUPLICATE of bug 316748
11 years ago
11 years ago

People

(Reporter: is+mozilla, Unassigned)

Tracking

({rtl})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; he-IL; rv:1.9b2pre) Gecko/2007121008 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; he-IL; rv:1.9b2pre) Gecko/2007121008 Minefield/3.0b2pre

This is a long standing issue, but having dutifully searched for it I can find no open bug report. 

In gtk theme, the down arrow overlaps the text when browser is in RTL mode (see atached image). Now that we are using native drop-downs in pages as well as UI, this becomes significantly more troublesome. 

Reproducible: Always

Steps to Reproduce:
1. start browser in RTL mode
2. open web page which has dropdown boxes
3. see text over lapping arrow
Actual Results:  
text ovelaps arrow

Expected Results:  
text should be entirely inside the text portion of the box.
(Reporter)

Comment 1

11 years ago
Created attachment 293436 [details]
screenshot illustrating problem.
(Reporter)

Updated

11 years ago
Attachment #293436 - Attachment description: screenshot illustrating porlbem. → screenshot illustrating problem.

Comment 2

11 years ago
Can you try a newer build? It should be fixed by bug 316748 ;)
(Reporter)

Comment 3

11 years ago
Sorry about that. I started firefox from the wrong directory. I just tried
Mozilla/5.0 (X11; U; Linux i686; he-IL; rv:1.9b3pre) Gecko/2007121604 Minefield/3.0b3pre
and got the same result. This should be the latest build, right?

Comment 4

11 years ago
Yes, it should have been fixed in that build... What theme are you using?
(Reporter)

Comment 5

11 years ago
Ack, this just isn't my computing day. I thought I was in using Clearlooks, but due to a a typo in my gtkrc I was actually using gtk-qt, which is known to have LTR issues. 

All other themes seemed to work, although I did notice a glitch in Geramik (see forthcoming snapshot). Is this a Geramik bug or a mozilla bug? 

Sorry for the inconvinience. 
(Reporter)

Comment 6

11 years ago
Created attachment 293442 [details]
glitch in geramik

See how the vertical separator is on the right rather than the left? This was the only RTL glitch I noticed in Geramik, which is why I wasn't immediately sure that the bug is in Geramik rather than firefox.

Comment 7

11 years ago
(In reply to comment #6)
> Created an attachment (id=293442) [details]
> glitch in geramik
> 
> See how the vertical separator is on the right rather than the left? This was
> the only RTL glitch I noticed in Geramik, which is why I wasn't immediately
> sure that the bug is in Geramik rather than firefox. 
> 

By looking at the source code of Geramik (or rather the qtpixmap theme engine it uses) I think this is because it does not look at the direction Firefox sets to the widget, so it draws the image for the widget LTR. Firefox separately defines the place where the drop down arrow should be drawn, that's why the drop down arrow is drawn in the correct place. I guess gtk-qt draws the arrow at the same time as the main widget, so that the arrow is misplaced as well.
 
I wonder if there are no issues with those themes on a Hebrew (RTL) OS?

I hope you don't mind me marking this bug as a duplicate of bug 316748
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 316748

Comment 8

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.