Saved form/AutoComplete information doesn't carry over to new tabs [unless the tab is manually refreshed/reloaded after creation]

RESOLVED DUPLICATE of bug 322750

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 322750
10 years ago
9 years ago

People

(Reporter: PCLM, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

If I open a link in a new tab - for instance, Google or other search engines - my previously entered form information is not available [unless I refresh the new tab manually].

I use the middle-mouse button to open links in new windows, and when I do this with the "Home" icon on the toolbar the same problem occurs - that is, I must left-click the icon again for the form data to become available in the newly created tab.  Of course the same applies if I CTRL+Click links to create new tabs, or indeed right-click on the link and select "Open Link in New Tab".

If I create a new blank tab, and then load up a search engine, the form data appears as normal.  It's only when the tab is created from a link or a bookmark that a manual refresh becomes necessary.

This problem has existed since at least version 1.5, when I first started using FireFox.  I've seen it mentioned in a round-about way before, but the "manual refresh" aspect hasn't been mentioned, which may shed more light onto what's causing the problem.

Reproducible: Always

Steps to Reproduce:
1. With Auto-complete enabled and some form information stored, visit any webpage
2. Open your favourite search engine in a new tab (from a bookmark or from your "Home" icon/other link).
3. Double-click the search box, or start typing, to see that no previously entered form data appears.
Actual Results:  
I was unable to recall the form data until I refreshed the newly created tab.

Expected Results:  
It should have recalled the previously entered form data without the need to refresh the new tab.

I'm using the standard, default theme.  I used a UI Tweaker extension to alter the toolbars and layout, but the problem existed before I did this.

I have used 4 entirely different PC systems since my first use of FireFox, and the problem has existed on all of them, so I doubt my system itself is responsible.

I have the following extensions/Add-ons installed, but again these have changed over the years and most were not installed when I first started using FireFox:

Adblock Plus 0.7.5.3
British English Dictionary 1.19
Clear Private Data... 0.2.1
FlashGot 0.7
IE Tab 1.3.3.20070528
SourceForge Direct Download 0.5
UI Tweaker (Formerly Toolbar Cleanup) 1.7.0
VideoDownloader 1.1.1

I'm using Windows XP Professional SP2 with all of the latest updates.

My FireFox version is the latest as of the date of writing this: 2.0.0.11.

In my FireFox settings, the "Tabs" section is setup as follows:

===================

New pages should be opened in:

[ ] a new window
[*] a new tab

[ ] Warn me when closing multiple tabs
[ ] Warn me when opening multiple tabs might slow down Firefox
[*] Always show the tab bar
[ ] When I open a link in a new tab, switch to it immediately

===================

My settings have changed throughout the years and the problem has been there the whole time.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

10 years ago
Having just installed Firefox 3.0 Final, I can now confirm that this issue still hasn't been addressed.

Comment 2

9 years ago
PCLM: Does this bug also manifest itself when you start Firefox in Safe Mode (i.e. without any extensions enabled)?

Comment 3

9 years ago
I confirm the same behavior with my FF 3.0.3. Whenever I open a link from my favorites tab with middle mouse-button click - the autocomplete list for form field (the first one) is empty. I've just noticed that when I switch focus to some other field (i.e. password field) and then back to the first field (i.e. username) - then autocomplete list shows up with remembered entries.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322750
You need to log in before you can comment on or make changes to this bug.