pngsuite images with chromaticities [cHRM] chunk rendered with incorrect colors

VERIFIED INVALID

Status

()

VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 293451 [details]
ccwn2c08.png

The pngsuite tests have 2 images with cHRM chunks:

ccwn2c08 - gamma 1.0000 chunk, chroma chunk w:0.3127,0.3290 r:0.64,0.33
           g:0.30,0.60 b:0.15,0.06
ccwn3p08 - gamma 1.0000 chunk, chroma chunk w:0.3127,0.3290 r:0.64,0.33 
           g:0.30,0.60 b:0.15,0.06

When displayed in the browser they are rather pale, in Gimp they are more saturated.

$ pngcheck -v -v ccwn2c08.png 
File: ccwn2c08.png (0 bytes)
  chunk IHDR at offset 0x0000c, length 13
    32 x 32 image, 24-bit RGB, non-interlaced
  chunk gAMA at offset 0x00025, length 4: 1.0000
  chunk cHRM at offset 0x00035, length 32
    White x = 0.3127 y = 0.329,  Red x = 0.64 y = 0.33
    Green x = 0.3 y = 0.6,  Blue x = 0.15 y = 0.06
  chunk IDAT at offset 0x00061, length 1397
    zlib:  deflated, 32K window, default compression
    zlib line filters (0 none, 1 sub, 2 up, 3 avg, 4 paeth):
      1 2 4 1 2 1 2 2 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4
      4 4 4 4 1 1 1 (32 out of 32)
  chunk IEND at offset 0x005e2, length 0
No errors detected in ccwn2c08.png (50.7% compression).
(Reporter)

Comment 1

11 years ago
Created attachment 293453 [details]
Screenshot of FF and Gimp

This shows how ccwn2c08.png looks in Firefox and Gimp, on OS X. Seems to look the same on a Linux desktop. Both systems have gfx.color_management.enabled set to false.
(Reporter)

Comment 2

11 years ago
Oh, crap, this is probably due to the gAMA chunk, as in bug 405398.

The PNG looks the same as the GIF version in pngsuite (other than dithering), so it's probably being rendered ok.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.