If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add a UI option to keep Download Manager open after download completes (browser.download.manager.closeWhenDone)

NEW
Unassigned

Status

Thunderbird
Preferences
--
enhancement
10 years ago
3 years ago

People

(Reporter: Brian S. Craigie, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

Request for enhancement: When you save an attachment or attachments in Thurderbird, it would be nice if the download manager window which appears briefly would stay visible after the files have been saved, to make it easy to access the files that have just been saved (and have an option to view it from the View menu).

This would be handy because I could more easily find the saved files (when one has  hundreds of folders for different customer's emails for example).  I'm sure this would benefit more people than just me. :-)



Reproducible: Always

Steps to Reproduce:
1. Locate an email with an attachment
2 [review]. right-click on the attachment and choose save (or save all) (or anything except open)
3. choose where to save it
Actual Results:  
file is saved correctly.  A download manager window briefly appears then disappears.

Expected Results:  
Would like the download manager window to remain visible.

Comment 1

10 years ago
->INVALID, At least for tb3, you only have to set browser.download.manager.closeWhenDone false.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
Thank you Magnus.

Just for other people's benefit, this works in Thunderbird 2 also.  For clarification, you make sure that Thunderbird is not running, then edit prefs.js and add the line:

user_pref("browser.download.manager.closeWhenDone", false);

Save the file, then start Thunderbird, and the download manager window stays open.  Hooray!

However, Thunderbird still needs an easier way to turn the download manager window on again (like in Firefox, where it is on Tools -> Downloads)

Therefore, may I humbly request that it be given a menu option?

Thanks.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

9 years ago
That's two different requests -- add a menu item to open the Download Manager, and an option (from comment #0's expected results) to leave it open when the download completes.  Both are fine, and would mirror Firefox, but there should only be one per bug (easier to implement that way), so I'm rewriting the summary for this one to reflect the original request, and confirming that.

Please feel free to file a separate enhancement request for the menu item idea -- I'm not seeing any duplicates for that one either.  CC me on it, and I'll confirm it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Thunderbird needs a download manager → Add a UI option to keep Download Manager open after download completes
(Reporter)

Comment 4

9 years ago
Thanks.  I've done that as 450861.
Component: Mail Window Front End → Preferences
QA Contact: front-end → preferences
Duplicate of this bug: 441195

Updated

9 years ago
Summary: Add a UI option to keep Download Manager open after download completes → Add a UI option to keep Download Manager open after download completes (browser.download.manager.closeWhenDone)

Updated

4 years ago
Blocks: 342154

Comment 6

4 years ago
Until such time we get the new download manager (as in current FF), which might take long, I suggest something should be done as a matter of urgency here to improve the UX of saving and then retrieving attachments.

Currently, when users save attachments, we save them without providing any obvious link back to the folder where attachments were saved, so users have to open their file manager and search for the very same files again. Odd.

Minimal fix:

Add options UI for this (as in old FF)
and probably set browser.download.manager.closeWhenDone = false (as default)

Thoughts?
(Reporter)

Comment 7

3 years ago
Yes please. I definitely rank this very highly desired.  When files have been saved, they should be listed in the download manager to make them easily accessed.  It can't be that hard surely? :-)
(Reporter)

Comment 8

3 years ago
I should add that when attachments are *opened* they get listed in the download manager window, but if the user right clicks an attachment and clicks "save" or the user clicks the "save all" button, *nothing* is listed in the download manager.
You need to log in before you can comment on or make changes to this bug.