If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CTRL-Z undo fails after paste from external app (e.g. abiword, open office). MailNews composer.

RESOLVED WORKSFORME

Status

()

Core
Editor
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: Bryce Mozilla Nesbitt, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070803 SUSE/1.1.4-20 SeaMonkey/1.1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070803 SUSE/1.1.4-20 SeaMonkey/1.1.4

There is a long standing bug with pasted text from external rich text applications like AbiWord and OpenOffice:


Reproducible: Always

Steps to Reproduce:
1. Compose a new MailNews message in AutoDetect or Rich Text modes.
2. Starting from Abiword or Open Office, select text or tables, and paste them into your message.

Actual Results:  
Undo won't get rid of the new text or tables.

And often the formatting of the message changes in a way that "discontinue text styles" won't fix.  Even switching the edit mode to plain text won't get rid of the fonts or styles applied.

Expected Results:  
Undo works.
"discontinue text styles" works.

I can make you a video tape of this happening.  It's happened for years -- this is not a new bug.

Comment 1

10 years ago
When I paste a table from OpenOffice Calc, I get
###!!! ASSERTION: JoinNode called with node not listed in offset table.: '0', file mozilla/editor/txtsvc/src/nsTextServicesDocument.cpp, line 2630
(1 of those for each cell)

When I try to undo, I get:

An error occurred executing the cmd_undo command
[Exception... "Node was not found"  code: "8" nsresult: "0x80530008 (NS_ERROR_DOM_NOT_FOUND_ERR)"  location: "chrome://global/content/globalOverlay.js Line: 86"]

Based on that and bug 290261 comment 4, this might be a dupe (if composer performs the paste by setting innerHTML), but I'll leave it open for now.
Assignee: mail → nobody
Status: UNCONFIRMED → NEW
Component: MailNews: Main Mail Window → Editor
Depends on: 290261
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: editor
Version: unspecified → Trunk
two seperate testers one with Linux/KDE (with paste from libreoffice) and another on windows, say its WFM.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.