Preference to Reply All by default

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: pepper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/523.10.3 (KHTML, like Gecko) Version/3.0.4 Safari/523.10
Build Identifier: 

Command-Shift-R does Reply All, but there should be a preference to Reply All by default (Command-R instead of Command-Shift-R), and make Reply (not All) Command-Shift-R.

This may be in Penelope already (it was in Eudora); it should be part of mainline Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.Read a message.
2.Command-R.
3.Review preferences for a configurable default Reply behavior.
Actual Results:  
Command-R is Reply.

Expected Results:  
Should be an option to toggle the default Reply behavior.
I don'tquite see what the point of this would be. So you can more easily get to the "Reply" state later if you change your mind? xref bug 248681

Comment 2

11 years ago
The key is that I should be able to #1: Reply All from the keyboard, and #2: Reply All with Command-R (the default) without making a conscious effort to remember that the default is not All.
Well, #1 is already possible.

Comment 4

10 years ago
I don't see a compelling argument for this.  But then I don't have a business case for it - indeed I find reply all to be too often abused. Anyway, the fact that eudora does this doesn't make this a bug in TB. => enhancement.
Severity: minor → enhancement

Updated

10 years ago
Component: General → Preferences
QA Contact: general → preferences
While a preference would help a certain number of users who knew about it I don't think it would fix the situation.  In bug 45715 we're looking at making Reply List the default.  However the reply / reply all problem is very tricky because it can possibly cause a lot of unneeded embarrassment for people or be a pain; depending on what went wrong.

At the recent moz camp eu several people had good ideas for making the inline reply / reply all system better without having a preference.  I'll try to post back to this bug or bug 45715 with those improvements as they are filed.

But I'd recommend WONTFIX for this particular avenue as the added preference is not going far enough to fix the problem.
Agreed
->WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.