closes the connection during the transfer from local proxy

VERIFIED INVALID

Status

()

P3
major
VERIFIED INVALID
19 years ago
19 years ago

People

(Reporter: hory, Assigned: gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; Linux 2.2.14 i586; Nav)
BuildID:    2000052520

When using a local offline proxy (like wwwoffle), mozilla closes the connection
towards the proxy if the requested page needs to be downloaded. This happens
even is I set the network.http.version to 1.0 or 0.9 in defaults/pref/all.js
file.
When trying to reload, the same thing happens.
This does almost never happen with netscape 4.7, and never happened with lynx or
w3m.
However, some pages download correctly every time (like www.tomshardware.com)
.

Reproducible: Always
Steps to Reproduce:
1. Fire up wwwoffled.
2. Turn wwwoffle online (exec 'wwwoffle -online')
3. Make sure that settings force wwwoffle to download www.hwsw.hu.
4. Start mozilla and go to www.hwsw.hu
5. You'll see the proxy's error message.


Actual Results:  Mozilla displayed the following message:

WWWOFFLE Remote Host Error

Your request for URL
http://www.hwsw.hu/news.php3?rovat=fooldal&ido=1.5
failed because
The client (browser) closed the connection during the transfer

This error message has now been deleted from the cache
Reloading this page will revert to the previous version.

Well, the latest statement is false when using mozilla, but true if I use any
other browser.

Expected Results:  Leave the connection towards the local proxy open and display
the page.
(Reporter)

Comment 1

19 years ago
After scanning through WWWOFFLE's sources it turned out to be WWWOFFLE's error.
Looks like mozilla closes the connection to the proxy if it does a refresh
(forced by the refresh tag in html's header).
The problem was that closing the connection generated an error message, which
was put into wwwoffle's cache, and re-read when mozilla tried to connect to it.
Turning on IntrDownloadKeep in wwwoffle.conf solved this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 2

19 years ago
verif. INVALID per reporter's comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.