Can't autoscroll in some application/xhtml+xml

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Jack Eidsness, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121705 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121705 Minefield/3.0b3pre

I don't know what the crucial difference is, but it looks to me like some pages that come in as application/xhtml+xml do not allow autoscroll.


Reproducible: Always

Steps to Reproduce:
This particular site has the same content on two different servers, at least for the moment.  One gives the MIME type as application/xhtml+xml, and the other gives it as text/html.  On the application/xhtml+xml site (with teh www in front), I can't autoscroll.  I did a diff of the page, and didn't see anything different except for ad links.

1. Go to http://www.techreport.com/discussions.x/13818 (note the application/xhtml+xml type. Also, it specifies the iso-8859-1 charset.)
2. try to autoscroll
3. Go to http://techreport.com/discussions.x/13818 (note the text/html type)
4. try to autoscroll; succeed
Actual Results:  
Autoscroll only works on the (no www) techreport.com site.

Expected Results:  
Autoscroll should be unaffected by this.

I don't know what the deal is with XML and autoscroll, but I know there have been other issues in the past.  On colorized XML text, middle-clicking used to make everything disappear, and I know there once was a problem with middle clicking links bringing up autoscroll instead of opening links in a new tab.
(Reporter)

Comment 1

11 years ago
I meant to add that I have definitely seen at least one other application/xhtml+xml page work with autoscroll.  It is conceivable that the xhtml+xml thing is a red herring.  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121810 Minefield/3.0b3pre

On both URLs I can autoscroll normally.
(Reporter)

Comment 3

11 years ago
It's working for me, again too, but also, both URLs are now showing text/html. I have no idea how to reproduce this.
(Reporter)

Comment 4

10 years ago
I can't attest to what exactly I saw so long ago, but I sure can't reproduce it, although for some reason, autoscroll only works in parts of that site other than their comments area, as of now (been that way for some time now).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.