Thunderbird/Pop/OS X opens attachments in the wrong location

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: Neville Hillyer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: 2.0.0.9

I am restricting this report to Thunderbird/Pop/OS X. It may relate to other situations but I believe the long history of this still unresolved bug demonstrates that there are probably difficulties finding a more general solution.

Thunderbird ignores its own preferences when opening attachments and uses the Safari download folder. Please note that for Pop this is clearly not a download issue as has often been reported.

Having spent some time reading around this I am of the opinion that Mozilla have not comprehended how frustrating this is for OS X users.



Reproducible: Always

Steps to Reproduce:
1. Double click attachment link in message
2.
3.
Actual Results:  
Typically many unwanted and unmarked items clutter the desktop until removed by user - I understand that an alternative destination can ONLY be set in SAFARI download preferences.

Expected Results:  
My preferred operation for many attachments is to view them inline or at the end of a message as several other mail clients do - (mail digests could also be better presented, just active links to each message would help, but this is another story).

If we cannot have this could we at least have Thunderbird defaulting to opening attachments in an out-of-sight temporary folder cleared by the application. I propose that users be permitted to change the location of this folder and the frequency of its automatic clearing. This does not prevent users saving to other locations. No data will be lost even without saving as the original message and attachment will normally still be in the Pop mail folder.



Please try to see this from an OS X Pop users point of view. As previously stated other users may be better served by alternative solutions.

I have raised this again as a 'Normal bug which should be fixed' - it is clearly not critical but the frustration it generates would cause some to declare it as 'Major'.
(Reporter)

Comment 1

11 years ago
I reported this as version 2.0.0.9 but the form field was ignored - perhaps I should have stated version 2.0.0.9 (20071031).

However, as far as I can tell, the bug has existed in earlier versions for several years.

Comment 2

11 years ago
And the Options | Attachments settings are correct? 
But that's for save, if you double click the attachment it's saved from the system tmp folder and opened from there. Is your system tmp folder set up correctly?
(Reporter)

Comment 3

11 years ago
Created attachment 294737 [details]
Attachment preferences

Attachment preferences as requested.
(Reporter)

Comment 4

11 years ago
Created attachment 294738 [details]
tmp folder details

tmp folder details as requested

Comment 5

11 years ago
All extensions disabled? If you create a new thunderbird profile, does it have the same problem?

Comment 6

10 years ago
No response to request for more information, so resolving as incomplete.

Reporter, please reopen if you're still having this problem and are able to help troubleshoot it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.