Flickering when creating new tab or closing last (and only) one

RESOLVED DUPLICATE of bug 543306

Status

()

--
major
RESOLVED DUPLICATE of bug 543306
11 years ago
7 years ago

People

(Reporter: mtanalin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2007121805 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2007121805 Minefield/3.0b3pre

In Fx 3, unlike Fx 2, there is flickering when:
1. creating new tab or
2. closing tab when this tab is only tab open at the moment while the option Tools -> Options -> Tabs -> "Always show the tab bar" is turned on.

That flickering effect is quite annoying and undesirable and even *dangerous* for epileptics in particular while evidently easy-to-fix.

Evident reason of this bug is that *window background* is shown *between* closed tab disappearing and next-to-focus tab (i.e. new tab on creating new tab, or "new" tab automatically created on closing tab which is already one and only open tab) is really shown. Solution is to prevent it by making transition *direct* from one tab to other tab without intermediate (short but noticeable) window background displaying.

Reproducible: Always

Steps to Reproduce:
1. create new tab;
2. create one more tab;
3. see to background of window at each iteration.
OR
1. turn on the option Tools -> Options -> Tabs -> "Always show the tab bar";
2. close all tabs except last one;
3. try to close last tab once and again;
4. see to background of window at each iteration.
Actual Results:  
Window background is displayed for a short while with noticeable flickering effect on creating every new tab or on trying to close last open tab.

Expected Results:  
Transition between two states (from one tab to another tab) should be direct, without intermediate window background displaying, as it is in Firefox 2 that have not this bug.

Firefox 3 is the first version of Firefox that have this bug.
(Reporter)

Comment 1

11 years ago
Ok, I've just checked Firefox 2 and discovered that this bug applies to it too to some extent. So, Firefox 3 is the first version of Firefox where this bug is *too noticeable* and enough to talk about it. Thanks.
To me the flickering is most noticeable when I am opening a new tab using  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

9 years ago
still see this?
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> still see this?

3.6 (Gecko/20100115 Firefox/3.6)—yes.
3.7 (Gecko/20100211 Minefield/3.7a2pre)—no.

It seems the bug is fixed in current 3.7 nightlies.
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Marat, would you have time to check which nightly build on 1.9.3 fixed that problem?
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
> Marat, would you have time to check which nightly build on 1.9.3 fixed that
> problem?

2010-02-01-04-mozilla-central (Minefield/3.7a1pre)—bug exists.
2010-02-02-05-mozilla-central (Minefield/3.7a1pre)—bug is fixed.
Thanks for re-checking. But I cannot see any candidate which could have fixed this bug. So we should leave it as WFM.
(Reporter)

Comment 8

9 years ago
Maybe depends on bug 543306 fixed on 2010-02-01.
That's it! Thanks. That check-in wasn't in the pushlog list for my query. Duping to bug 543306.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 543306
(Reporter)

Comment 10

9 years ago
By the way, this bug is reported far earlier than bug 543306, so I'm unsure the duping direction is right. ;-)
Resolution: DUPLICATE → WORKSFORME
(Reporter)

Comment 11

9 years ago
Oh, I have accidentally resetted status (planned to just add comment). Reverting now.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 543306
Time is relative. The patch on bug 543306 has already been fixed the issue. So the direction is correct.
(Reporter)

Updated

7 years ago
See Also: → bug 725756
You need to log in before you can comment on or make changes to this bug.