Edit folder name on Bookmark Toolbar or in main pane of Library does not dynamically update in the Library sidebar

VERIFIED FIXED in Firefox 3 beta3

Status

()

P2
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: tracy, Assigned: mak)

Tracking

Trunk
Firefox 3 beta3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
seen on: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2007121904 Minefield/3.0b3pre and the equivalent Win XP build.

STR:

1) open the Library, open the Bookmarks Toolbar folder, leave the Library open.
2) Go back to the browser and change the name of a folder on the Bookmark toolbar.

tested results:
the item is not updated in Library sidebar until the library is closed and reopened. However, the folder name edit is updated in the main view.

expected results:
The folder name changes in all locations, including the sidebar.

Comment 1

11 years ago
Confirmed.  Both by myself (on a Mac) and bug #409060 which is a dupe and a user on Windows.
(Reporter)

Updated

11 years ago
Duplicate of this bug: 413300
(Reporter)

Comment 3

11 years ago
Folder name changes made anywhere should dynamically update everywhere that folder appears. 

Note: closing then re-opening the Library does reflect the changed folder name in the sidebar.
Flags: blocking-firefox3?
drivers: this should block. can't ship with live-update broken.
Priority: -- → P2
(Assignee)

Comment 5

11 years ago
Created attachment 299162 [details] [diff] [review]
update visible items only when ExcludeItems is true

this i caused by excludeItems

a partial fix to this was already checked-in in 398295 then backed out to investigate on a TS regression, then it would have been checked-in with 399866 but still not done.

I've changed that so it still don't update non visible items, but updates visible ones
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #299162 - Flags: review?(dietrich)
Comment on attachment 299162 [details] [diff] [review]
update visible items only when ExcludeItems is true

looks good, thanks. r=me.
Attachment #299162 - Flags: review?(dietrich) → review+
Comment on attachment 299162 [details] [diff] [review]
update visible items only when ExcludeItems is true

drivers: low impact fix for a live-update issue.
Attachment #299162 - Flags: approval1.9?
Comment on attachment 299162 [details] [diff] [review]
update visible items only when ExcludeItems is true

a=beltzner for 1.9
Attachment #299162 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Flags: blocking-firefox3?
Keywords: checkin-needed
Checking in toolkit/components/places/src/nsNavHistoryResult.cpp;
/cvsroot/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp,v  <--  nsNavHistoryResult.cpp
new revision: 1.129; previous revision: 1.128
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M11
Duplicate of this bug: 409060

Comment 11

11 years ago
*** VERIFIED on Firefox Nightly PreB4. WORKS.
Please mark this as VERIFIED.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008022806 Minefield/3.0b4pre

-Mike

(Reporter)

Comment 12

10 years ago
verified with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081003 Minefield/3.1b1pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.