Right-Clicking on Radio buttons in Preferences screen will toggle the radio buttons state without regards to the radio group.

VERIFIED DUPLICATE of bug 51796

Status

()

P3
normal
VERIFIED DUPLICATE of bug 51796
19 years ago
18 years ago

People

(Reporter: killj0y, Assigned: bugs)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Mozilla Nightly Build (Build ID: 2000052815)

1) Open the edit/preferences... screen.
2) Click on the Navigator heading in the Category listbox.
3) Begin right clicking on the various radio buttons in the "When navigator
starts up, display" section.

----> 4) Notice that the radio buttons will toggle on or off as you right click
on them, but they do not follow traditional radio group behaviour.  That is, you
can enable multiple radio boxes (or none at all).

Comment 1

19 years ago
WFM with 2000-05-28-09 on Linux. When I click on the radio buttons in
Edit -> Preferences -> Navigator, I get messages like:
*** unchecking element 1
*** unchecking element 2
and the buttons behave as expected.
(Reporter)

Comment 2

19 years ago
Cyril,

Are you RIGHT clicking? The bug is in regards to RIGHT clicking on the radio 
buttons.  If you were right clicking and the buttons worked as desired, then 
this may be a Windows issue.

Comment 3

19 years ago
Tested with Build # 2000060208 on Windows 98 SE

RIGHT clicking on buttons allows multiple selections
able to reproduce everytime.

bug is probelly related to bug 41139 and may be a duplicate of it.

Comment 4

19 years ago
a widgets item. updating component
Assignee: matt → trudelle
Status: UNCONFIRMED → NEW
Component: Preferences → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: sairuh → jrgm

Comment 5

19 years ago
I am unable to reproduce this as described, although if I right-click quickly 
in succession (i.e, double-right-click) I can get it to change, but 
following the radio group rules exactly as with the left button. reassigning to 
ben.
Assignee: trudelle → ben

Comment 6

19 years ago
Alan,
sorry for the late reply. I did right clicking (also "quick" right clicking)
and it WFM with 2000-05-28-09 on Linux. It also WFM with 2000-06-09-08.

Comment 7

19 years ago
Tested on Build 2000060908 On Win 98 SE

I am no longer able to reproduce this bug.
Works for Me
(Reporter)

Comment 8

19 years ago
Well, I rechecked the bug on Nightly 2000060820 (Win98) and it seems this bug
has been fixed.  Right-clicking on a radio button no longer selects that radio
button.  However,  I also noticed Peter Trudelle's observation that double-right
-clicking on the radio button does select the radio button.  But, in that case
the radio group behaviour is followed correctly.

Comment 9

18 years ago
I can confirm this bug. Build 2000101014 on Win98 SE. Freshly installed. I 
noticed that it took a double-right-click to activate the radio button. Also, 
the preference is not changed by doing this.

Comment 10

18 years ago
Dup of bug 51796?
Fabian.

Comment 11

18 years ago
I'm marking this a duplicate of bug 51796, if you don't like it reopen.
Fabian.

*** This bug has been marked as a duplicate of 51796 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Verifying as a duplicate of bug 51796 
'Right clicking on XUL radio button checks button without unchecking others'
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.