Closed Bug 409119 Opened 14 years ago Closed 14 years ago

HTTP requests from Flash never have referer headers

Categories

(Core :: Plug-ins, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 410904

People

(Reporter: v-z, Unassigned)

Details

User-Agent:       Opera/9.25 (Windows NT 5.1; U; ru)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Requests Flash objects do not send http referer information in header.

Example: if website have 'hotlink protection' and flash mp3 player - it will be not able to play files, because of blank referer.

Reproducible: Always

Steps to Reproduce:
1. Uploade to your hosting any flash wich use external files
2. Open web page with this object in your browser
3. Check your server logs - you will not see referer

Actual Results:  
71.***.63.*** - - [20/Dec/2007:02:34:57 +0300] "GET /download/***.mp3 HTTP/1.1" 302 390 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11"

Expected Results:  
71.***.63.*** - - [20/Dec/2007:02:34:57 +0300] "GET /download/***.mp3 HTTP/1.1" 302 390 "http://www.site.com/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11"

This happen on all versions of firefox, all OS and all version of flash.

There is no such problem in Internet Explorer and Opera.

In my example was used WordPress with PodPress plugin.
What version of flash are you using?
about:plugins will tell you - and make sure you only have one version listed.

Have you tested on Firefox 3.0 beta 2?
It was tested from different computers and by my friends too. I just tried again default v2 and v3 installations again (fresh installs):


"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11"
+
Shockwave Flash (only one)
File name: NPSWF32.dll
Shockwave Flash 9.0 r115

and

"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2"
+
Shockwave Flash (only one)
File name: NPSWF32.dll
Shockwave Flash 9.0 r115


same results as before.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
The flash plugin itself does not allow to send the referrer
dupe of bug 337766  (The reporter is from macromdia)
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 337766
I incorrectly dupes this to bug 337766 and that bug is about manually adding a referrer
Duplicate of bug: 410904
You need to log in before you can comment on or make changes to this bug.