TypeError: productID is null

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: maulik.vaidya, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

while opening the webpage at the link above, a typeError is obtained. This is not the case while using Mozilla version 2.x

Reproducible: Always

Steps to Reproduce:
1. go to http://www.businessweek.com/technology/content/dec2007/tc20071218_959709.htm
2.
3.

Updated

11 years ago
Version: unspecified → Trunk

Updated

11 years ago
Keywords: regression

Updated

11 years ago
Keywords: qawanted
Visiting that page in Firefox 2.0.0.11, I get the same popup. Furthermore, digging into the source shows that they're trying to match http://app.businessweek.com/UserComments/combo_review?action=list&style=wide&productId=null&productCode=null with |var productID = sourceLink.match(/productid=(\d+)/i);| which is returning null and causing the error. This might be INVALID (although I'm willing to be proved wrong here).
I'm still seeing it on trunk and Shiretoko: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090415 Minefield/3.6a1pre ID:20090415030845

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090416 Shiretoko/3.5b4pre ID:20090416030924


...and the following attached screenshot occurs on IE 7 as well as Safari 3.2.1 (5525.27.1)
Created attachment 373169 [details]
Safari and IE 7 ScreenShot
Created attachment 373170 [details]
Actual Safari and ScreenShot
Attachment #373169 - Attachment is obsolete: true
Since this is happening across a majority of the top browsers, I'm going to close this as Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: qawanted
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.