Zooming a lone image has unexpected results

RESOLVED DUPLICATE of bug 389756

Status

()

RESOLVED DUPLICATE of bug 389756
11 years ago
11 years ago

People

(Reporter: tom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

This occurs when attempting to zoom an image on its own that is not displayed as part of a Web page. Specifically, when the image is larger than the view pane.

The image starts out scaled down to fit the view pane. The effects of Ctrl++ and Ctrl+- are temporary and the image is scaled back to the size of the view pane. Ctrl+0 also appears to have no effect in this state.

When the image is clicked to return it to its proper size, the effects of +,-, and 0 have evidently taken place.
i.e.
1. Image appears scaled down to the size of the view pane
2. Ctrl++ => image scales up and then back to the scaled-down size
3. Click image => image scales up to the size it would be if it was first scaled to regular size then Ctrl++ was clicked

Once the image has been clicked, Ctrl++ and Ctrl+0 work as expected, but Ctrl+- causes the image to return to the scaled down state in which all the above problems still occur and it cannot be reverted without once again clicking the image.

The expectation is that, when the image is full-size, Ctrl++, -, and 0 should work as with any other Web page. As for the case when the image is scaled-down, I would probably expect the image to become full-size when Ctrl+0 is pressed, and perhaps Ctrl++, and - would full-size the image and _then_ change the size.

Smaller images are affected in a similar way only if when zooming they become larger than the view pane. Images zoomed to be larger than the view pane shrink back to the size of the view pane and must be clicked to become the size they should be. It is expected that images that start out smaller than the view pane should never be shrunk to the size of the view pane since the user was the one that caused the image to overflow the pane.

I notice now that for lone images the View>Zoom menu is greyed out, but the keyboard shortcuts are still functional. I think it would be useful to be able to zoom lone images with a little more control than just having scaled-down or full-size options.

Reproducible: Always

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389756
You need to log in before you can comment on or make changes to this bug.