Closed Bug 409202 Opened 12 years ago Closed 10 years ago

'gtk-select-all' not present in theme, produces red X in Debian

Categories

(Firefox :: Menus, defect)

3.0 Branch
x86
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: mozilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

I can't speak for all engines/themes, but Clearlooks and Raleigh (the Debian default) don't have icons for "Select All." This produces a red X icon and the following when the Edit menus is selected the first time:

(firefox-bin:3515): Gtk-WARNING **: Error loading theme icon for stock: Icon 'gtk-select-all' not present in theme

Reproducible: Always

Steps to Reproduce:
1. Click the Edit menu
2.
3.
Stock icons are independent from the GTK theme engine.

I'm sure this error is caused by running with an outdated GTK (< 2.10). It was discussed multiple times to make GTK 2.10 the minimum requirement for Firefox 3 and there are other places where FF3 depends on at least GTK 2.10. Did you build FF3 by yourself or are you running a precompiled version?

There's a complete list here¹.

[1] http://wiki.mozilla.org/Linux/Runtime_Requirements
This is 3.0b2 directly from the release announcement. I guess that makes sense, the stock GTK on Debian 4.0/Etch/stable is:

libgtk2.0-0 2.8.20-7
Yes... the GTK_STOCK_SELECT_ALL was introduced in GTK 2.10.
Alright, I'll just watch for anything else that breaks based on that version. It's a shame to have an 8 month-old distribution get left out in the cold, but obviously the package freeze and release cycles of Debian aren't the problem of Mozilla.
Summary: Many (most?) GTK themes don't have "Select All" icons, produces red X → 'gtk-select-all' not present in theme, produces red X in Debian
I know there are rules for what we support, but there are functions that let you add stock icons. I haven't seen to code, but I imagine it wouldn't be that hard to create an interface that would add the icon (of course, this would require a new icon, I believe)
Sure... but won't even Debian have a new release (featuring GTK 2.10) out by the time Firefox 3 is out? I doubt they will officially push it into the current release. And let's not forget that GTK 2.10.0 was released well over a year ago, on 07/03/2006...

I know GTK supports creating its own "icon themes". Would this help? If we put all icons that we ship with the FF3 chrome into such a theme as a fallback but use "real" icon theme icons with a higher priority. This would actually let us extend the set of GTK stock icons to the fdo spec. But I guess this is not the option for FF3 anymore...
(Let me preface by saying I'm shooting from the hip on the following:) Given Debian's ~2 year effective release cycle, I think it'll probably be closer to a year and a half before a Stable release is out that includes a newer Gtk suitable for overlaying Fx3 on. For reference, my setup is always Debian Stable + the latest Mozilla.com Firefox release in /usr/local, not the Debian Fx-alike package that is maintained with security updates. Anyway, just trying to drum up some ideas, thanks for the feedback.
A bit off-topic, but did I dream that debian would do shorter cycles in the future? Hmm...
Nightly build Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008010704 Minefield/3.0b3pre displays following warnings on Ubuntu 6.06 LTS (which is based on Debian) when I open Edit menu (next to File menu):

(Gecko:6608): Gtk-WARNING **: Error loading theme icon for stock: Icon 'gtk-select-all' not present in theme

(Gecko:6608): Gtk-WARNING **: gtkwidget.c:7322: widget class `GtkSeparatorMenuItem' has no property named `wide-separators'

These warnings are probably caused by old GTK version (2.8.20) distributed by old Ubuntu release. Also see bug 409204.

I think that this issue may be ignored, though; Both Debian and Ubuntu distribute their own version of Firefox and can fix these problems itself even if they decide not to upgrade the GTK libraries. If the user really wants to jump to Firefox 3.0, they probably shouldn't be running Debian Stable or Ubuntu LTS version in the first place.

Just make sure to list minimum GTK version in the system requirements.
This should be fixed meanwhile by further updates of Debian and Ubuntu. Given that this bug is invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.