If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

infinite loop setting location.href twice in BODY' as onLoad

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
P1
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Stefan Vassall, Assigned: zach)

Tracking

({crash, dom0, testcase})

Trunk
crash, dom0, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lm], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build no. 2000052720 (Linux - XFree86 4.0)

Entering the above URL in the address bar, and then trying to load crashes mozilla!

To repeat, simply visit the above page in moz!
In the text window I see infinite cycling of the messages:

Document: Done (13.189 secs)
*** check number of frames in content area 

Marking confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Simply crashes the mozilla! → Page causes infinite loop
Created attachment 9303 [details]
simplified testcase
Changing component to DOM Level 0.  The problem is that there is an infinite
loop when setting location.href twice in BODY's onLoad.
Assignee: asadotzler → jst
Component: Browser-General → DOM Level 0
QA Contact: jelwell → desale
Summary: Page causes infinite loop → infinite loop setting location.href twice in BODY's onLoad
Upping priority
Status: NEW → ASSIGNED
OS: Linux → All
Priority: P3 → P1
Hardware: PC → All
This must be fixed for nsbeta3
Keywords: nsbeta3
Target Milestone: --- → M18
JavaScript 1.1 backward compatibility (correctness of legacy code
interpretation) and crash (product hangs). PDT team please approve.
Keywords: correctness, crash

Comment 7

17 years ago
Marking nsbeta3+
Whiteboard: [nsbeta3+]

Comment 8

17 years ago
Please advise: is bug 42060 a duplicate?

Comment 9

17 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration, but do not clear 
the nsbeta3- nomination.
Whiteboard: [nsbeta3+] → [nsbeta3-][lm]
Target Milestone: M18 → Future
There shouldn't be this simple ways to crash a product. Sorry guys, removing 
nsbeta3-... 

Besides, there are potentially related bugs that are also on nsbeta3 lists. See 
bug 42060, bug 47279 and bug 48382.
Whiteboard: [nsbeta3-][lm] → [lm]
Target Milestone: Future → ---
Restoring [nsbeta3-]. "No simple ways to crash a product" is not the criterion 
we're using. Time left to ship date, resources available, and importance of bug 
is. The workaround for this bug is simple: don't set location.href twice. 
Heikki, don't remove nsbeta3-es unless you're reassigning the bug to yourself.
Whiteboard: [lm] → [nsbeta3-][lm]
Marking evangwanted. Someone please contact the site owner and ask them to fix 
their code.
Keywords: evangwanted
(Assignee)

Comment 13

17 years ago
Site has been informed. Adding evangelized keyword and removing 
evangwanted keyword. Stealing bug from jst, sorry.
Assignee: jst → zach
Status: ASSIGNED → NEW
Keywords: evangwanted → evangelized
(Assignee)

Comment 14

17 years ago
Accepting before I get more whiney email.
Status: NEW → ASSIGNED
Oh no, don't take my bugs! (Just kidding) :-)

I just tested this on linux and it appears to be fixed...

Comment 16

17 years ago
CC'ing Radha
quite similar to one of eric's bugs

Comment 18

17 years ago
Actually, I think it may be a dup of Rick's bug 48382 as Heikki noticed above.

This is worksforme today too though (Linux tip build).  Either way, even if it's
not fixed it should probably be fixed when 48382 is fixed...
Summary: infinite loop setting location.href twice in BODY's onLoad → infinite loop setting location.href twice in BODY' as onLoad

Updated

17 years ago
Keywords: evangelized
Keywords: dom0

Updated

17 years ago
Keywords: nsbeta3 → testcase
Whiteboard: [nsbeta3-][lm] → [lm]

Comment 19

17 years ago
I tested this with win95 with current trunk & it seems fixed. I didn't see any 
crash. & also according to eric it should be fixed when bug 48382 is fixed. Bug 
48382 is fixed & verified.
Marking this one fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 20

17 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 21

9 years ago
Crashtest added as part of http://hg.mozilla.org/mozilla-central/rev/5a6def05ccbc
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.