Support HTML targets on reftests

RESOLVED FIXED

Status

Testing
Reftest
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Waldo, Assigned: Waldo)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 294104 [details] [diff] [review]
Patch

I had to slightly tweak comment processing to ignore # not at the start of a line and not preceded by whitespace, and the drawWindow call had to be changed to account for possible scrolling.

This is needed for an acid2 reftest that's modified as little as possible, because the acid2 test URL relies on a #top target to test scrolling.
Attachment #294104 - Flags: review?(dbaron)
Comment on attachment 294104 [details] [diff] [review]
Patch

r=dbaron

But what about acid2 making assumptions about fonts that it probably shouldn't be?  (Don't have time to find the bug right now.)
Attachment #294104 - Flags: review?(dbaron) → review+
Given that not many people are hitting the font issue (bug 404698 for easy
reading), I'm going to try dropping the current version on the tree and seeing
if tinderboxen like it.  If tinderbox barfs or somebody running reftests
complains, we remove the bottom row from the test and the image and commit
that.  We really should have this tested automatically (however imperfectly we
can do it, assuming Hixie doesn't end up making a fixed version), since a
regression basically constitutes an automatic blocker.
In, doesn't seem to regress any existing tests -- acid2 test executes (doesn't
pass yet everywhere, but that's another issue), so this looks good.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Component: Layout: Misc Code → Reftest
Flags: in-testsuite+
Product: Core → Testing
Target Milestone: mozilla1.9beta3 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.