valgrind: Conditional jump or move depends on uninitialised value(s) [@ nsProxyObjectCallInfo::CopyStrings]

RESOLVED FIXED in mozilla1.9beta3

Status

()

--
minor
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

({valgrind})

Trunk
mozilla1.9beta3
valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

11 years ago
valgrind: Conditional jump or move depends on uninitialised value(s) [@ nsProxyObjectCallInfo::CopyStrings]

The problem is the null-check here:
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/xpcom/proxy/src/nsProxyEvent.cpp&rev=1.98&root=/cvsroot&mark=229,231#219
because 'val.p' may not have been fully initialized if it's a shorter type:
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/xpcom/reflect/xptcall/public/xptcall.h&rev=1.31&root=/cvsroot&mark=126,128,157#118

There is no harm done in CopyStrings() because it checks the type_tag before
using the value. But it makes 'valgrind' noisy and suppressing this message
seems wrong, so I think it should be fixed.
(Assignee)

Comment 1

11 years ago
Created attachment 294108 [details]
valgrind messages
(Assignee)

Comment 2

11 years ago
Created attachment 294109 [details] [diff] [review]
Like so?
(Assignee)

Updated

11 years ago
Attachment #294109 - Flags: superreview?(bzbarsky)
Attachment #294109 - Flags: review?(bzbarsky)
Comment on attachment 294109 [details] [diff] [review]
Like so?

I can't review this; I'm no an XPCOM peer.  Please ask someone who is?
Attachment #294109 - Flags: superreview?(bzbarsky)
Attachment #294109 - Flags: review?(bzbarsky)
(Assignee)

Updated

11 years ago
Attachment #294109 - Flags: superreview?(benjamin)
Attachment #294109 - Flags: review?(benjamin)

Updated

11 years ago
Attachment #294109 - Flags: superreview?(benjamin)
Attachment #294109 - Flags: superreview+
Attachment #294109 - Flags: review?(benjamin)
Attachment #294109 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #294109 - Flags: approval1.9?
Assignee: nobody → mats.palmgren

Updated

11 years ago
Attachment #294109 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 4

11 years ago
mozilla/xpcom/reflect/xptcall/public/xptcall.h 	1.32 

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11

Updated

11 years ago
Duplicate of this bug: 411068
Keywords: valgrind

Comment 6

11 years ago
Any reason to have "val.p = nsnull;" in both the if and else instead of above them?
You need to log in before you can comment on or make changes to this bug.