testopia is not compatible with new JSON

RESOLVED FIXED

Status

Testopia
Test Cases
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Jeff Vogelsang, Assigned: Greg Hendricks)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0, Firefox 2.0.0.11, Testopia 1.3 BETA2, Bugzilla 3.0.2

Using the Testopia version in Build Identifier, select boxes fail to populate when they are AJAX enabled. Using Firebug, you can trace the tr_quicksearch.cgi call, and read the response, which contains an error. The error is: "Can't locate object method autoconv via package JSON"

My environment was built using CPAN to get the required Perl modules, including the JSON module. As of today, the JSON version available on CPAN is 2.01. In this version, autoconv has been moved to its own module. This is causing the the tr_quickseach.cgi call to fail.

Reproducible: Always

Steps to Reproduce:
1. Install Testopia 1.3 BETA2
2. Install JSON 2.01 from CPAN
3. Attempt to add a new test case.
Actual Results:  
Product Version select box doesn't populate.

Expected Results:  
Product Version select box should populate.

My solution was to downgrade the JSON version to 1.14. You can remove the JSON 2.01 CPAN installed version using the information here: http://www.cpan.org/misc/cpan-faq.html#How_delete_Perl_modules.

Then, Fedora at least (likely other Redhat distros as well), you can "yum install perl-JSON". This will get you version 1.14 of JSON through Fedora package management.

Updated

10 years ago
Summary: Product Version select list fails to populate. (Others fail as well.) → testopia is not compatible with new JSON
(Assignee)

Comment 1

10 years ago
It can also be downloaded from CPAN.org directly at http://search.cpan.org/~makamaka/JSON-1.14/
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Duplicate of this bug: 388015

Comment 3

10 years ago
See also https://bugzilla.mozilla.org/show_bug.cgi?id=388015#c6

Comment 4

10 years ago
While this resolved my instance of the bug, the information included re: removing a Perl module is out of date. The link no longer points to the correct information.

Correct procedure assuming CPAN was used for the install -

$> perl -MCPAN -e shell 
> look JSON
(output from CPAN, land in shell in directory containing JSOD source files)
# perl Makefile.PL
# make uninstall

Uninstall is unsafe and deprecated, the uninstallation was not performed.
We will show what would have been done.

(List of 11 or so files to be deleted) 

Uninstall is unsafe and deprecated, the uninstallation was not performed.
Please check the list above carefully, there may be errors.
Remove the appropriate files manually.
Sorry for the inconvenience.

# rm (copy in file paths from above) 

# exit
 (Back to CPAN)

> exit

$ install older version of JSON by any method

Comment 5

10 years ago
Thanks very much for this info, Matt.

Comment 6

10 years ago
Steps to install JSON

perl -MCPAN -e shell 
install M/MA/MAKAMAKA/JSON-1.14.tar.gz
exit

I then restarted Apache and nothing had changed. I reboots (shutdown -r now) and when the server started back up (Ubuntu 7.10 with LAMP) everything was working fine.

Comment 7

10 years ago
I still get JSON errors with 1.14 and 1.13. Anyone know where to get 1.07?
(Assignee)

Comment 8

10 years ago
What kind of errors? Testopia has been tested with 1.14 and is known to work.

Comment 9

9 years ago
This is going to be very unhelpful... they started working auto-magically a couple of days later.

Sorry.. no more repro. 
(Assignee)

Updated

9 years ago
Duplicate of this bug: 428884

Updated

9 years ago
Duplicate of this bug: 429259
(Assignee)

Updated

9 years ago
Duplicate of this bug: 437828
(Assignee)

Comment 13

9 years ago
    /cvsroot/mozilla/webtools/testopia/Bugzilla/WebService/Testopia/TestPlan.pm,v  <--  TestPlan.pm
    new revision: 1.22; previous revision: 1.21
    done
    Checking in Bugzilla/Testopia/Build.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Build.pm,v  <--  Build.pm
    new revision: 1.22; previous revision: 1.21
    done
    Checking in Bugzilla/Testopia/Environment.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Environment.pm,v  <--  Environment.pm
    new revision: 1.26; previous revision: 1.25
    done
    Checking in Bugzilla/Testopia/Search.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Search.pm,v  <--  Search.pm
    new revision: 1.53; previous revision: 1.52
    done
    Checking in Bugzilla/Testopia/TestCaseRun.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/TestCaseRun.pm,v  <--  TestCaseRun.pm
    new revision: 1.54; previous revision: 1.53
    done
    Checking in Bugzilla/Testopia/TestTag.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/TestTag.pm,v  <--  TestTag.pm
    new revision: 1.10; previous revision: 1.9
    done
    Checking in Bugzilla/Testopia/Product.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Product.pm,v  <--  Product.pm
    new revision: 1.21; previous revision: 1.20
    done
    Checking in Bugzilla/Testopia/Classification.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Classification.pm,v  <--  Classification.pm
    new revision: 1.7; previous revision: 1.6
    done
    Checking in Bugzilla/Testopia/TestRun.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/TestRun.pm,v  <--  TestRun.pm
    new revision: 1.54; previous revision: 1.53
    done
    Checking in Bugzilla/Testopia/Attachment.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Attachment.pm,v  <--  Attachment.pm
    new revision: 1.24; previous revision: 1.23
    done
    Checking in Bugzilla/Testopia/Category.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Category.pm,v  <--  Category.pm
    new revision: 1.18; previous revision: 1.17
    done
    Checking in Bugzilla/Testopia/Util.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Util.pm,v  <--  Util.pm
    new revision: 1.12; previous revision: 1.11
    done
    Checking in Bugzilla/Testopia/TestPlan.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/TestPlan.pm,v  <--  TestPlan.pm
    new revision: 1.59; previous revision: 1.58
    done
    Checking in Bugzilla/Testopia/TestCase.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/TestCase.pm,v  <--  TestCase.pm
    new revision: 1.61; previous revision: 1.60
    done
    Checking in tr_process_case.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_process_case.cgi,v  <--  tr_process_case.cgi
    new revision: 1.13; previous revision: 1.12
    done
    Checking in tr_builds.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_builds.cgi,v  <--  tr_builds.cgi
    new revision: 1.16; previous revision: 1.15
    done
    Checking in tr_run_reports.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_run_reports.cgi,v  <--  tr_run_reports.cgi
    new revision: 1.13; previous revision: 1.12
    done
    Checking in tr_quicksearch.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_quicksearch.cgi,v  <--  tr_quicksearch.cgi
    new revision: 1.22; previous revision: 1.21
    done
    Checking in tr_xmlrpc.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_xmlrpc.cgi,v  <--  tr_xmlrpc.cgi
    new revision: 1.8; previous revision: 1.7
    done
    Checking in tr_history.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_history.cgi,v  <--  tr_history.cgi
    new revision: 1.5; previous revision: 1.4
    done
    Checking in tr_query.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_query.cgi,v  <--  tr_query.cgi
    new revision: 1.19; previous revision: 1.18
    done
    Checking in tr_list_cases.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_list_cases.cgi,v  <--  tr_list_cases.cgi
    new revision: 1.40; previous revision: 1.39
    done
    Checking in tr_new_environment.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_new_environment.cgi,v  <--  tr_new_environment.cgi
    new revision: 1.10; previous revision: 1.9
    done
    Checking in tr_new_plan.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_new_plan.cgi,v  <--  tr_new_plan.cgi
    new revision: 1.20; previous revision: 1.19
    done
    Checking in tr_process_run.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_process_run.cgi,v  <--  tr_process_run.cgi
    new revision: 1.12; previous revision: 1.11
    done
    Checking in tr_list_caseruns.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_list_caseruns.cgi,v  <--  tr_list_caseruns.cgi
    new revision: 1.41; previous revision: 1.40
    done
    Checking in tr_process_plan.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_process_plan.cgi,v  <--  tr_process_plan.cgi
    new revision: 1.6; previous revision: 1.5
    done
    Checking in tr_environments.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_environments.cgi,v  <--  tr_environments.cgi
    new revision: 1.2; previous revision: 1.1
    done
    Checking in tr_new_case.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_new_case.cgi,v  <--  tr_new_case.cgi
    new revision: 1.24; previous revision: 1.23
    done
    Checking in tr_caserun.cgi;
    /cvsroot/mozilla/webtools/testopia/tr_caserun.cgi,v  <--  tr_caserun.cgi
    new revision: 1.4; previous revision: 1.3
    done
    Checking in testopia/patch-3.0;
    /cvsroot/mozilla/webtools/testopia/testopia/patch-3.0,v  <--  patch-3.0
    new revision: 1.14; previous revision: 1.13
    done
    RCS file: /cvsroot/mozilla/webtools/testopia/testopia/testrunner.pl,v
    done
    Checking in testopia/testrunner.pl;
    /cvsroot/mozilla/webtools/testopia/testopia/testrunner.pl,v  <--  testrunner.pl
    initial revision: 1.1
    done
    Checking in testopia/patch-3.0.x;
    /cvsroot/mozilla/webtools/testopia/testopia/patch-3.0.x,v  <--  patch-3.0.x
    new revision: 1.5; previous revision: 1.4
    done
    Checking in testopia/js/caserun.js;
    /cvsroot/mozilla/webtools/testopia/testopia/js/caserun.js,v  <--  caserun.js
    new revision: 1.42; previous revision: 1.41
    done
    rlog: /cvsroot/mozilla/webtools/testopia/testopia/js/caserun.js,v: warning: Unknown phrases like `commitid ...;' are present.
    Checking in Bugzilla/Testopia/Environment/Property.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Environment/Property.pm,v  <--  Property.pm
    new revision: 1.12; previous revision: 1.11
    done
    Checking in Bugzilla/Testopia/Environment/Element.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Environment/Element.pm,v  <--  Element.pm
    new revision: 1.13; previous revision: 1.12
    done
    Checking in Bugzilla/Testopia/Environment/Category.pm;
    /cvsroot/mozilla/webtools/testopia/Bugzilla/Testopia/Environment/Category.pm,v  <--  Category.pm
    new revision: 1.15; previous revision: 1.14
    done
    Checking in testopia/doc/pod/webservice/CHANGELOG;
    /cvsroot/mozilla/webtools/testopia/testopia/doc/pod/webservice/CHANGELOG,v  <--  CHANGELOG
    new revision: 1.3; previous revision: 1.2
    done
    Checking in testopia/t/data/dummy_load.sql;
    /cvsroot/mozilla/webtools/testopia/testopia/t/data/dummy_load.sql,v  <--  dummy_load.sql
    new revision: 1.2; previous revision: 1.1
    done
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.