Corrupted string of being installed component shown during installation

RESOLVED FIXED in Firefox 3

Status

()

Firefox
Installer
P2
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: heidan, Assigned: rstrong)

Tracking

({intl})

Trunk
Firefox 3
x86
Windows XP
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

see attached screen shot.

Reproducible: Always

Steps to Reproduce:
1.Download Firefox 3.0b2
2.Run installation package
3.Notice the component string shown during installing process. Some corrupted string displayed there.
Actual Results:  
corrupted component name displayed

Expected Results:  
component name should appear correctly

Now sure if it relates to encoding issue. Below please find my regional settings:
* Standards and format: China (PRC)
* Location: USA
* Language used in menu and dialogs: English
* Language for non-Unicode application: Chinese(PRC)
* East Asian font support installed.

Updated

10 years ago
Keywords: intl
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Keywords: intl
Whiteboard: firefox 3.0b2
Version: Trunk → unspecified

Updated

10 years ago
Keywords: intl
Version: unspecified → Trunk
Confirming.

My settings are:

Current Format: English (United States)
Current Location: Singapore
Display Language: English
Current language for non-unicode programs: Chinese (PRC)

This is a pretty obvious UI issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 303510 [details]
screenshot

A screenshot showing the installer window on the right and my "Advanced" tab of the regional and language options in Win XP.
Duplicate of this bug: 409914
I also have East Asian font support installed.

Nominating due to impact on Asian l10n.

If you look at the reporter's screenshot in the URL, the jumbled characters make no sense. For the screenshot in comment #2, the jumbled characters are supposed to mean "Browse"; instead the word is not shown.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2

Updated

10 years ago
Assignee: nobody → robert.bugzilla
Duplicate of this bug: 420063

Updated

10 years ago
Whiteboard: firefox 3.0b2 → [needs status update]
re: whiteboard note - 

About needing status update, issue still occurs when the font support is installed, alternative locale to Chinese, and running the Beta 5 installer.
Not sure of the cause though I might be able to fix this... using an English installer when the OS non-unicode charset is set to Chinese(PRC) has previously been very difficult to fix.
Whiteboard: [needs status update] → [eta unknown see comment 7]
Created attachment 312952 [details]
zipped test installer

Would someone that is experiencing this bug try this attached installer to see if it fixes it? Thanks!

btw: the test installer will quit before it makes any changes so it is safe to test with
Created attachment 312967 [details]
screenshot

Unfortunately the issue still exists.
Created attachment 312979 [details]
zipped test installer 2

Thanks Gary... could you or someone else try out this test installer? Thanks again.
Attachment #312952 - Attachment is obsolete: true
Created attachment 312992 [details] [diff] [review]
patch rev 1 - convert unicode ellipsis to ...
Attachment #312992 - Flags: review?(benjamin)
Whiteboard: [eta unknown see comment 7] → [has patch][need review]
Created attachment 312993 [details]
zipped test installer 3 created via patch
Target Milestone: --- → Firefox 3
Attachment #312993 [details] fixes both the "Browse..." button and the original reporter's issue.
Target Milestone: Firefox 3 → ---
Target Milestone: --- → Firefox 3

Updated

10 years ago
Attachment #312992 - Flags: review?(benjamin) → review+
Checked in to trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][need review]
Duplicate of this bug: 427150

Updated

10 years ago
Duplicate of this bug: 431455
You need to log in before you can comment on or make changes to this bug.